Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 48 of 48
  1. #41
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    23

    Quote Originally Posted by AdioNN View Post
    Was absent for several months, and I see this problem is still present. It is so frustrating, when you need bios update to fix one laptop problem, yet you cannot update because it will cause another one. Should we just open new tickets every week just to remind them of this problem? At least we have a good workaround in this thread. Oh yea, I can't restart computer without it getting stuck AsusRog logo either, every windows update is like a game, I wonder will my PC work after restart or not...
    Yeah Ive been fine with BIOS 302, and just check backed today after a few months STILL NO UPDATE! And beyond that now BIOS 302 has been removed. WTF ASUS? I really cant believe they haven't addressed this yet.*

    If youre having this problem keep filing tech support or complaint tickets every so often, maybe we can get through to them. *
    Last edited by Narkanin; 11-21-2019 at 06:54 AM.

  2. #42
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    6

    Just went through this same issue- GL702VM won't get past ROG logo with a Samsung QVO 860 attached. I'm returning it. BIOS 310.
    Are there any known SATA SSDs that work well with ASUS in this scenario?

  3. #43
    ROG Enthusiast Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    41

    Quote Originally Posted by superchomp View Post
    Just went through this same issue- GL702VM won't get past ROG logo with a Samsung QVO 860 attached. I'm returning it. BIOS 310.
    Are there any known SATA SSDs that work well with ASUS in this scenario?
    I am running with the same problem know also with GL702VM on BIOS310 which was installed from windows updater last summer.

    I am trying to replace my stock HDD per Crucial MX500 SATA SSD and stucks on ROG logo with no signs of life.

    Do anyone knows a solution for this problem?

  4. #44
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    23

    It's unbelievable this still hasnt been addressed. I will not be buying another Asus, thats for sure.

  5. #45
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    2

    Gl504gw

    Hi guys,

    just found a bios update on asus USA site with version 306 dated 2020/06/05

    should i attempt to install?

    i have:

    1- Samsung SSD 970 EVO 540GB NVME M.2 (windows 10 is installed on it)
    2- Samsung SSD 860 EVO 2TB Sata

    if i install the update will i have the problem?

    Update:


    Installed v 306 BIOS and worked like a charm with current configuration
    Last edited by ahassouna; 06-08-2020 at 01:37 AM.

  6. #46
    ROG Guru: Orange Belt Array raju2529 PC Specs
    raju2529 PC Specs
    Laptop (Model)R542UQ-DM153 ( X542UQ.309 )
    MotherboardAsus Builtin Motherboard X542UQ
    ProcessorIntel core i5 7200u @2.5Ghz
    Memory (part number)Adata 2400 Mhz 16GB
    Graphics Card #1intel Hd 620 graphics 1GB DDR3 DCH WHQL driver v27.20.100.8425
    Graphics Card #2Nvidia GeForce 940MX 2GB GDDR5 DCH WHQL driver v27.21.14.5167
    Graphics Card #3nil
    Graphics Card #4nil
    Sound CardRealtek HD Audio controller with codec 294 WHQL driver v6.0.8975.1
    MonitorBuiltin Lcd monitor model BOE
    Storage #1Samsung 850 Evo 250GB SSD M.2. 2280
    Storage #2Seagate 2TB 2.5inch. Toshiba 1TB 2.5 inch
    CPU CoolerBuilt-in
    CaseFrom factory
    Power Supply65W
    Keyboard Built in keyboard
    Mouse Built in mouse
    Headset Purchased Philips HeadSet
    Mouse Pad nil
    Headset/Speakers Realtek Builtin Speakers
    OS Windows 10 Enterprise 64bit v2004 build no 19041.331
    Network RouterBsnl Wi-Fi modem with router
    Accessory #1 Dell Wired Mouse
    Accessory #2 Laptop Cooling table with fan
    Accessory #3 Secureye Usb finger print scanner added seperately for Windows Hello
    raju2529's Avatar
    Join Date
    Feb 2018
    Reputation
    9
    Posts
    305

    If it contains nee micro code for processots means , you must update latest bios.

  7. #47
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    23

    Quote Originally Posted by ahassouna View Post
    Hi guys,

    just found a bios update on asus USA site with version 306 dated 2020/06/05

    should i attempt to install?

    i have:

    1- Samsung SSD 970 EVO 540GB NVME M.2 (windows 10 is installed on it)
    2- Samsung SSD 860 EVO 2TB Sata

    if i install the update will i have the problem?

    Update:


    Installed v 306 BIOS and worked like a charm with current configuration
    You have given me hope, kind of nervous to try it given all the issues I had getting it back to normal last time, but since it worked for you thats promising.

    Wait where are you seeing this new BIOS? Im still only seeing one from 2019.

  8. #48
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Narkanin View Post
    You have given me hope, kind of nervous to try it given all the issues I had getting it back to normal last time, but since it worked for you thats promising.

    Wait where are you seeing this new BIOS? Im still only seeing one from 2019.
    sorry dude, just saw ur msg.
    my model is Gl504gw if it's the same i can send u the link but if it's not then i don't recommend it.

Page 5 of 5 FirstFirst ... 3 4 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •