Results 1 to 10 of 10

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Apr 2018
    Reputation
    12
    Posts
    6

    GL502VSK Bricked BIOS Update

    Hi All

    Looking for some help with a failed BIOS update on a GL502VSK.

    It looks like a BIOS update was pushed out through Windows Update and the update started to run when I rebooted the machine, which is strange in itself as it caught me unaware during such a critical process. Anyway, unfortunately the update hung 3/4 way through

    I now have a machine that won't POST. When I power on, get the usual LED's but complete black screen. I have tried putting a copy of the 309 BIOS (tried 308 as well) onto a USB stick and using the Ctrl & Home method but nothing. However, I think a positive is that the USB activity light flashes briefly, stops for a couple of seconds, then flashes again for a few more seconds. But ultimately still nothing.

    So I think it is trying to read something from the USB but isn't finding what it is looking for. Can anyone assist with what the file name should be? I've tried AMIBOOT.ROM AMIBOOT.309 GL502VSK-AS.ROM GL502VSK-AS.309 GL502-VSKAS.CAP etc

    If anyone has any other suggestions as well that would be great

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •