Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    1

    Asus RoG GL703GE Battery Charging Issues

    Hello,

    My girlfriend recently purchased a GL703GE. For the past month or so, the battery does not charge above 31%. If she discharges the battery completely, it will charge to 84% or so, but that seems to be largely illusionary as the battery will sometimes catastrophically discharge to 0% and cause the computer to shutdown when not plugged in. When the laptop is plugged in, it says "Plugged in, Not Charging" in the battery status area, and the little red battery light blinks repeatedly.

    She has asked me to help with this problem since I'm a bit more tech savvy than she is and have more time to mess with it. Since the battery is internal and non-removable without removing the bottom of the case, I have not tried removing it or swapping it. So far I have tried 1) updating the battery detection drivers, 2) downloading ASUS's battery app and changing the battery power mode, 3) holding the I/O switch for 60 seconds to do a hard reset of the computer (this one works, but only for a few hours), 4) updating the BIOS to the latest version (this one worked for a whole day, but the problem reoccurred.

    Given that the battery seems to be functioning when it is allowed to properly charge, my guess is this might be a driver or software issue apart from the BIOS, or not corrected in the most recent BIOS update. However, I am not sure, and since it seems a great deal of ASUS laptops the whole way back to the early 2010s have this problem, I have found a plethora of information online that is not relevant to her computer and does not seem to work. Any advice would be greatly appreciated.

    Her next step will be to contact the warranty center, but from what I've read around here, that doesn't really seem to fix anything and may cause additional headaches.

  2. #2
    ROG Enthusiast Array
    Join Date
    Feb 2019
    Reputation
    28
    Posts
    44

    Quote Originally Posted by ah1cm View Post
    Hello,

    My girlfriend recently purchased a GL703GE. For the past month or so, the battery does not charge above 31%. If she discharges the battery completely, it will charge to 84% or so, but that seems to be largely illusionary as the battery will sometimes catastrophically discharge to 0% and cause the computer to shutdown when not plugged in. When the laptop is plugged in, it says "Plugged in, Not Charging" in the battery status area, and the little red battery light blinks repeatedly.

    She has asked me to help with this problem since I'm a bit more tech savvy than she is and have more time to mess with it. Since the battery is internal and non-removable without removing the bottom of the case, I have not tried removing it or swapping it. So far I have tried 1) updating the battery detection drivers, 2) downloading ASUS's battery app and changing the battery power mode, 3) holding the I/O switch for 60 seconds to do a hard reset of the computer (this one works, but only for a few hours), 4) updating the BIOS to the latest version (this one worked for a whole day, but the problem reoccurred.

    Given that the battery seems to be functioning when it is allowed to properly charge, my guess is this might be a driver or software issue apart from the BIOS, or not corrected in the most recent BIOS update. However, I am not sure, and since it seems a great deal of ASUS laptops the whole way back to the early 2010s have this problem, I have found a plethora of information online that is not relevant to her computer and does not seem to work. Any advice would be greatly appreciated.

    Her next step will be to contact the warranty center, but from what I've read around here, that doesn't really seem to fix anything and may cause additional headaches.
    I had the same issue, after my motherboard has been dead, then has been changed in the warranty with another bad motherboard. Plugged in, Not Charging + frames drops in all games. Without AC Charger connected, the laptop working fine. No frames drops. The who play games with battery only when no charging anymore....
    Send it to the service again (in warranty) and now I have another new motherboard (possible new revision) + a new battery.

    So I think you must change the battery first or both. Mobo + Battery.

    My laptop is GL703GM
    Last edited by GeoBRB; 07-27-2019 at 03:42 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •