Results 1 to 3 of 3

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Feb 2017

    ROG GL502VS-DS71 automatic EZ flash bricked laptop help

    Hi all. 2 days ago I turned my laptop on, all I did was push power them walk away. When I came back it had went right in to ezflash and was trying to do something but it all locked up.

    I'm working away from home and I didn't have any bios files loaded or internet (not that that would work) on powering off and back on I get a power light, a caps lock light and the external power light. All lights are solid. There is seemingly no power to the screen as it is completely black, there is no backlight to it. I've pulled the nvme and both batteries for a while and replugged them and tried to restart the laptop to no avail.

    I've tried holding down multiple buttons etc... On power up but nothing makes a difference.

    I paid 2 grand for this laptop and I'm desperately hoping it's not completely bricked.

    Any help would be amazing.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts