Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    1

    Exclamation [GL502VMK] No display after failed bios update. Built-in keyboard not working

    So I think it is fair to say that I have got myself into a bit of a pickle.

    One day, I come to open my laptop like every other day except this day was different. I had to wait for a bios update at the asus flashing bios thing which came after booting. However, at the middle of the update, my laptop just turned off. I don't know if it was a power issue or if something went wrong with the update. I then tried to open my laptop to only come to no display of anything at all, not even a boot logo.

    Like every other person, I went to the forums here to check out whether anyone else had the same problem, and there were. I tried doing the holding esc for several seconds then down arrow and enter, that didn't work. Last option I had was to go to the bios at boot. So I tried every single combo I knew including Ctrl+Home. It was only after I did all that I did that I realised I had fast startup on which disables usb ports on boot. The reason this is important is because I was using my external razer keyboard to do everything since my built-in laptop keyboard stopped working a long time ago, I didn't really pay much attention to the fact that it stopped working because I never really used it.

    I am going to some local repair shop soon, but I was wondering if anyone on the forums here knows what to do about the predicament I have gotten myself into.*
    Last edited by Ethylio; 06-19-2019 at 11:59 AM. Reason: Forgot to mention something.

  2. #2
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    27
    Posts
    310

    That non functioning keyboard is probably gonna make things a lot harder. You have to use the built-in KB to trigger the bios recovery thing. I don't think it would work using an external keyboard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •