Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Jun 2019

    ASUS FX570UD BIOS update 310

    Hi everyone

    Hope we all keeping well today

    I need help as I am not all that computer savy, I recently updated my ASUS FX570UD with a new update that came through the windows 10 update app

    The laptop was reset and then the BIOS was updated, however I am stuck in a loop now as the pc starts up but does not go into windows 10 at all

    It keeps going to the trouble shooting option - I have tried to do a system restore, full format, windows repair but still no avail, it simply keeps resetting and keeps telling me " Diagnosing problem " or " Fixing error "

    Is there anyone out there that can help me ? what do I do ? is it fixable ? how do I revert back to my old BIOS ? I go into the EZ utility screen but there is no option there to back track to a previous version and I cannot go into windows at all to fix it that way either as it just want let me.

    Thanks in advance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts