Results 1 to 2 of 2

Hybrid View

  1. #1
    ROG Member Array
    Join Date
    Dec 2012

    Maximus X Hero - Realtek Audio Manager not showing up!


    Im on Windows 10 1903 buildnr 18362.175 and having major issues to get the Realtek Audio Manager to work.
    Tried the Asus official driver and UAD, HDA driver published in this forum without success!

    Noticed that Asus website has 2 different ones on their site for this motherboard.
    Regular Realtek and some Nahimic - whats the difference and why is there 2 different ones for the same motherboard?

    Any help?

  2. #2
    ROG Enthusiast Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus X Hero (Wi-Fi)
    Processori7 8700K
    Memory (part number)HX433C16PB3K4/32
    Graphics Card #1EVGA GTX 1080 Ti
    Sound CardOn Board
    MonitorLG 34UC89G
    Storage #1Samsung 970 Pro 1 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard Black Widow Ultimate
    Mouse Logitech G600
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X53

    Join Date
    Jan 2014

    I suppose you are not showing a large speaker icon in the hidden icons on the Taskbar?

    I run the normal driver and it works fine after the build upgrade. I once looked for an answer as to why two drivers, but that info seems to be shrouded in mystery...possibly additional functionality in the second one. If you go through the extremely long and out of date thread, you may find some sort of answer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts