Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    2

    No Windows 7 drivers for Crosshair VII found on Asus Website

    Hello all. I've been forced to to an emergency new build to replace my failed nine year old MSI mobo. I bought the x470 Crosshair VII because I know I will be able to drop in a Ryzen Gen2 CPU later this year, but for the moment am going to use a Ryzen 5 2600 I had lying around.

    The Asus site (under Specifications) clearly states that the board will accept Windows 10 or 7. I went to Support to download BIOS and drivers and stuff, but there are no listings for Chipset or Lan drivers for Windows 7 64-bit.

    Am I going to be able to install Windows 7 to this board? Not ready to change my whole setup to Windows 10 so please don't suggest. Thank you.

  2. #2
    ROG Junior Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    2

    Quote Originally Posted by MoKiChU View Post
    Hi,

    AMD Chipset Drivers for your X470 motherboard (Windows 7 64 bit) : https://www.amd.com/en/support/chips...ocket-am4/x470
    Intel Ethernet Driver for your X470 motherboard (Windows 7 64 bit) : https://downloadcenter.intel.com/download/18713
    Well thank you...now I feel like an idiot. It didn't occur to me to check AMD's site. Geez, I'm such an a**hole. Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •