Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    28
    Posts
    3

    G75VW replaced GPU and wont boot [solved]

    G75VW 670m GPU fried and i replaced it with the same part # GPU. The keyboard and indicators light up, Hard drive makes a noise with intel/ROG on screen, but shuts off right away, fans dont turn on. any advice?
    Last edited by XGamer12; 04-23-2019 at 06:28 AM.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    318
    Posts
    7,726

    I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

    Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    28
    Posts
    3

    Thank you. I will disassemble again, reseed and check over again. I will post an update.

    Quote Originally Posted by xeromist View Post
    I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

    Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.

  4. #4
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    28
    Posts
    3

    toying with it some more today and i popped up the keyboard and armrest. The power cable completely removed from the motherboard and the keyboard. i didnt know that it could unhook from the keyboard aswell.. well i reconnected them and starting the laptop it booted and went to windows!! i guess this could be one thing to check aswell for those having boot problems..

    update: upon closer look the cable between the power button and motherboard has split and doesnt have good contact. ordering a new power/mb cord.

    Quote Originally Posted by xeromist View Post
    I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

    Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.
    Last edited by XGamer12; 04-25-2019 at 03:52 AM.

  5. #5
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    1

    help

    Hello, where did you get your gpu from, been searching for over a month for the 670m with limited success
    Quote Originally Posted by XGamer12 View Post
    G75VW 670m GPU fried and i replaced it with the same part # GPU. The keyboard and indicators light up, Hard drive makes a noise with intel/ROG on screen, but shuts off right away, fans dont turn on. any advice?

  6. #6
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    Quote Originally Posted by adeboye View Post
    Hello, where did you get your gpu from, been searching for over a month for the 670m with limited success
    Try to Private Message (PM) XGamer12 directly.
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •