Results 1 to 7 of 7

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    3

    Exclamation M.2 NVMe disks disappeared after CPU/BIOS update

    Hello everyone

    I recently built a PC using the ROG Strix B450 F Gaming MOBO along with an Ryzen 5 2600 CPU. Then I added two M.2 SSD later on, one of em being the Kingston A1000 960GB, and my it worked like a charm <3

    But lately, after I switched my CPU from Ryzen 5 2600 to Ryzen 7 2700X, which my MOBO supports, and after flashing my BIOS, the M.2 SSDs are no longer visible anywhere in my BIOS nor at any OS running over USB, like Linux for example. Its just like the M.2/NVMe disks disappeared forever. I still have my M.2 Disks connected to the Mobo, but I can't see them or detect them in the BIOS disk list. In the BIOS it says: No disks are connected. And I can't find any settings related to the SATA/PCIe mode on the M.2 slots.

    I tried resetting the BIOS settings, I tried disabling CSM, I tried locating the disks in any list inside BIOS, I can't locate the disks nor find any bootloader, so I tried absolutely everything :/ Everything worked fine before I switched the CPU and flashed the BIOS. I was so mad yesterday, so I just bought a new 1TB Samsung SSD and installed this instead via SATA port 0. The PC is working fine now. But the M.2 slots, or the disks, are either corrupted or defect, in my opinion. Or the slots are defect on the MOBO. What could have caused this? Does anyone know if there's any setting in the BIOS or anything I could try? Or resetting the CMOS, would this help?

    Here are my parts I use today:

    MOBO: ROG Strix B450 F Gaming

    CPU: Ryzen 7 2700X (supported on the mobo)

    M.2 SSD: Kingston A1000 960GB M.2 SSD (does not work any longer / Connected directly on the MOBO)

    M.2SSD: Samsung PM981 SSD 256GB M.2 PCIe SSD (does not work any longer / Connected directly on the MOBO)

    2.5" SSD: Samsung 860 QVO 1TB SSD (works like a charm using SATA Port 0)

    The PC worked fine using the M.2 disks mentioned over "before" I upgraded the CPU. Afterwards they just disappeared. Now, the PC works fine using the older type of Samsung 2.5" SSD Disk via SATA Port 0.

    Thank You in advance for any advice or help I can get.
    Last edited by erlendkrool; 06-28-2019 at 02:46 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •