Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    19

    How can I stop GRID trying to install?

    I had a popup (I assume from EZ Update) saying a new version of GRID was available and clicked to install it (hoping the flaws from GRID beta were fixed).

    The install stalled at somewhere between 10-15% and never finished even after leaving it for an hour. I had to reboot and when I after I did so the GRID install popped up again with no option to refuse it or close it. Now the install sits at zero percent and never moves. I've had to use task manager to kill it. I've had to do a couple more reboots since and every time the GRID install pops up and does nothing, needing to be killed with Task manager each time.

    I've tried to locate what is triggering this with no success. I couldn't find anything using Autoruns. So I assume EZ Update is just launching it every time I reboot.

    So two questions;

    How can I get it to actually install?

    or

    How can I get it to stop trying to install on every reboot?

    edit: More information: The program that actually runs is "AsusDownLoadLicense.exe" and it seems to be in c:\windows\system32. Looking in that folder I can see a few more files that are likely related; syncas.dll, AsusDownloadAgent.exe, wpbbin.exe and AsusUpdateCheck.exe

    I've also located a folder c:\program files (x86)\Asus\AsusGridInstallPackage which looks (obviously) like it contains the setup files for GRID. However, the dates on that are back in 2018 so I suspect they're leftovers from the GRID beta.

    None of which is telling me what is actually triggering the install
    Last edited by skrybe; 07-04-2019 at 08:55 AM.

  2. #2
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    19

    Well this is getting even worse, I've tried moving the files from system32 related to the GRID install out and a reboot just brings them back.

    I've tried disabling the Asus Update Service using Task manager and it' re-enabled on reboot. There is apparently no way to stop the Asus updates appearing on reboot. This is ridiculous (bordering on virus) behaviour.

    I guess my next step is completely uninstalling everything related to Asus and starting over with *just* drivers.

    Well, even uninstalling EZ Update doesn't work. This is flat out ridiculous...
    Last edited by skrybe; 07-04-2019 at 09:36 AM.

  3. #3
    ROG Member Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    19

    I think I've finally resolved the GRID weirdness. Even deleting anything GRID related in the registry and file system didn't seem to work. On a whim I checked the BIOS on the 2nd last reboot and discovered there is an option there about the GRID install service (IN THE FREAKIN BIOS!) I disabled that and after a reboot it looks like GRID has finally stopped trying to install.

    I'm sorry Asus but this is terrible design. At the very least you need to provide some indication in the app installer in windows that it's being installed FROM THE BIOS. That way users can turn it off instead of wasting four hours on this stupid problem.

  4. #4
    New ROGer Array MrStanUp PC Specs
    MrStanUp PC Specs
    MotherboardB450 F Gaming
    ProcessorRyzen R7 3700X
    Graphics Card #1Nitro+ Vega 56
    MrStanUp's Avatar
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    1

    Solution

    I had the same problem, visited many sites in my search for a solution.

    The setting to disable is in the BIOS!
    Click image for larger version. 

Name:	gridInstall.jpg 
Views:	0 
Size:	108.1 KB 
ID:	80999

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •