Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    1

    fx504 Stuttering and frames drop

    i just buy Asus Tuf gaming fx504 last week. Then i try to play fortnite with it and i keep dropping frames from 100+ to 1 FPS. I also have the same problems with overwatch and world of warcraft. I dont know what to do anymore and i feel like i have made the worst decision in my life. I already reinstall the graphic card, check update for everything, use high performance in power option. I hope anyone here can help my problems

    Proccessors: I5-8300H
    Graphic card: Nvidia GeForce 1050
    RAM: 4GB RAM

  2. #2
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    3

    I Really understand the pain. I have been facing this issue on my FX504GD for 3 months. After doing several attempts, reinstalling drivers, undervolting etc. Somehow it worked fine today. It works perfectly now. Gives me a huge boost in FPS in every game (aabout 25+). Can you give me the screenshot of Power Options- High Performance(Change plan settings)- Advance power settings- processor power management - Expand both Minimum power and maximum power state and upload the screenshot. I may help you get your boi back

  3. #3
    ROG Guru: Orange Belt Array ThrashZone PC Specs
    ThrashZone PC Specs
    MotherboardASUS x99 sabertooth & x299 Rampage VI Apex
    Processori7-5930k & i9-9940x
    Memory (part number)Trident-Z 3200C14 & Trident-Z 3600C16 both Samsung B-Dies
    Graphics Card #1EVGA 1080ti FTW3 water block & Titan Xp copper water block
    MonitorAOC G2460PG 24"G-Sync 144Hz & ASUS VG248QE 24" 144Hz
    Storage #12-Samsung 970 Evo Plus 500gb M.2 & 2.5" ssd's 850 pro's for os 850 evo for games
    Storage #22-LG Blu-Ray WH16NS40
    CPU Coolerx99 2-240GTX with Heatkiller-4-Pro/ vrm water block Both&x299 2-280GTX 2-D5's before and after rads
    Case2- Corsair 450D with second floors for 240GTX & 280GTX rads enclosed and filtered on top
    Power SupplyEVGA 1000P2 & EVGA 1200P2
    Keyboard Logitech G910 Orion Spectrum & Logitech G710+
    Mouse 2-Red dragon Perdition
    OS Win-7 & win-10 pro on both systems Win-7 everyday os
    Accessory #1 Heatkiller IV Pro plexi/ Copper base on both systems
    Accessory #2 Mayhems Biocide and Inhibitor with distilled water
    Accessory #3 Mayhems 3/8-5/8" clear soft tubing
    ThrashZone's Avatar
    Join Date
    Oct 2017
    Reputation
    13
    Posts
    319

    Hi,
    4gb's of memory can't help a lot
    What's the config 2x2gb or 1x4gb sticks and at what speed 1600/.... ?

  4. #4
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    1

    Clock speed

    Quote Originally Posted by maxfield3009 View Post
    I Really understand the pain. I have been facing this issue on my FX504GD for 3 months. After doing several attempts, reinstalling drivers, undervolting etc. Somehow it worked fine today. It works perfectly now. Gives me a huge boost in FPS in every game (aabout 25+). Can you give me the screenshot of Power Options- High Performance(Change plan settings)- Advance power settings- processor power management - Expand both Minimum power and maximum power state and upload the screenshot. I may help you get your boi back
    Hi, Can you say what's the clock speed of your cpu in idle mine crossing base clock of 2.3Ghz

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •