Results 1 to 2 of 2
  1. #1
    ROG Member Array Mr Blue Playdoh PC Specs
    Mr Blue Playdoh PC Specs
    MotherboardAsus Z97-DELUXE(NFC&WLC) ATX LGA1150 Motherboard
    ProcessorIntel Core i7-4770K 3.5GHz Quad-Core Processor
    Memory (part number)G.Skill Ripjaws X Series 16GB (2 x 8GB) DDR3-1600 Memory
    Graphics Card #1EVGA GeForce GTX 780 Ti 3GB Superclocked Video Card (2-Way SLI)
    Graphics Card #2EVGA GeForce GTX 780 Ti 3GB Superclocked Video Card (2-Way SLI)
    MonitorAsus ROG SWIFT PG278Q 144Hz 27.0" Monitor
    Storage #1Samsung 840 EVO 250GB 2.5" Solid State Drive
    Storage #2Western Digital Caviar Black 1TB 3.5" 7200RPM Internal Hard Drive
    CPU CoolerCorsair H100i 77.0 CFM Liquid CPU Cooler
    CaseFractal Design Define XL R2 (Titanium Grey) ATX Full Tower Case
    Power SupplyEVGA SuperNOVA 1000 P2 1000W 80+ Platinum Certified Fully-Modular ATX Power Supply
    Keyboard Razer Blackwidow Ultimate
    Mouse Logitech G9x
    Headset Sennheiser PC 363D
    Mouse Pad Steelseries
    OS Microsoft Windows 7 Home Premium SP1 OEM (64-bit)

    Join Date
    Jul 2015

    Rog maximus xi extreme bios 1105

    Hello guys, Ok i noticed my BIOS is very out of date and when i try to update it it says not bios file or some thing like that.
    I did a search and says about formating USB to FAT32 which i did i tried quick formate and the long formate and it still dont work i also tried 3 different USB sticks and i know they worked as i did a bios update before.

    What i have noticed is the file icon has an icon that you have if its a image file not sure if this has any thing to do with it.

    Ok so i just tried using the BIOS before this one and same thing. Looks like i can not update.
    Last edited by Mr Blue Playdoh; 07-12-2019 at 12:35 PM.

  2. #2
    ROG Member Array Eguun PC Specs
    Eguun PC Specs
    MotherboardAsus ROG MAXIMUS XI EXTREME (Z390 EATX)
    ProcessorIntel(R) Core(TM) i9-9900K CPU @ 3.60GHz
    Memory (part number)Corsair DOMINATOR® PLATINUM 16GB (2 x 8GB) DDR4 4000MHz (SKU: CMD16GX4M2E4000C19 ver 4.31)
    Graphics Card #1MSI - NVIDIA GeForce RTX 2080 8 GB GAMING X TRIO
    Storage #1Samsung SSD 970 PRO 512GB
    Storage #2Samsung SSD 960 PRO 512GB
    CPU CoolerNoctua NH-D15
    CaseCooler Master MasterCase H500M
    Power SupplySeaSonic - PRIME Ultra Titanium 650 W 80+ Titanium
    Mouse SteelSeries Rival 500
    Headset ROG Centurion true 7.1
    OS Windows 10 Pro 64bits

    Join Date
    Feb 2018


    There are several ways to update your BIOS, which one are you using that display such misbehavior?
    Have you tried other ways to update the BIOS?

    Beware on that specific BIOS version, which is reported by several users here (including me) as not working as intended. Sources:

    1005 version (the one just prior to 1105) works as intended (at least for me).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts