Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    massive FPS drops. (cut in half). software issues related on ASUS ROG 503GE

    I bought this laptop 2 months ago. the issue started 2 weeks ago..
    no changes were made whatsoever.

    so the issue is.. when Im playing a game, for like 5-10minutes. fps were constantly drop in half. example:
    RE2 Remake = 60fps to 20-30
    Spec Ops The Line = 120fps to 50-60

    only happens on a game that requires dedicated GPU. game like Age Of Empires 2 doesnt suffer from this as this game is automtically run on Intel HD

    this happens regularly every 5minutes or less then back at normal, then it happens again. Im always playing on plugged in, everyone knows that.
    and no.. its not the graphics settings... a normal FPS drop would only happens on a game and area where its to hard for the hardware to process or render.
    this issue happens, even if Im idle in a MAIN MENU, LOADING SCREEN, even on a CINEMATIC TRAILER.. like why would fps drop happens while Im playing a movie file????
    all hardware are still in fine condition,its a new afterall... no overheating problem, no fan problem
    the PROBLEM WAS.. the GPU is somehow turned into a POWER SAVING MODE. reducing the performance. and auto switched into INTEL HD GRAPHICS. how is this happening? r u kidding me??? this piece of cr- laptop DOESNT EVEN KNOW IM RUNNING A GAME???

    took it to the service center and has no result, guys there dont have any idea.. if any of you can help me, I'll appreciate it.. otherwise I'll ask for a refund on this. clearly this was a faulty driver or even the hardware.
    if this was proven to be factory faulty, then you shouldnt sell this model anymore... lots of people suffer the same issues as me.
    Last edited by kmkmkmkmkmkm; 07-13-2019 at 11:32 AM.

  2. #2
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    5

    We understand your frustration but you don't have to behave like this while trying to explain what it's happening to you.

    It would be better to leave us some information like what kind of specifications do you have, like your graphic driver or some screenshot of your settings on nVidia for those games.

  3. #3
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    Quote Originally Posted by aRonio View Post
    We understand your frustration but you don't have to behave like this while trying to explain what it's happening to you.

    It would be better to leave us some information like what kind of specifications do you have, like your graphic driver or some screenshot of your settings on nVidia for those games.
    ASUS ROG 503GE
    i7-8750H 2.2hz
    Nvidia GTX 1050Ti
    8GB Ram
    256Gb SSD
    1Tb HDD

    Nvidia CP setting is set to default: balanced
    battery settings is set to: max performance

    Nvidia driver is up to date: 431.36
    win 10 is up to date: 1903

    already tried to reset the whole thing, see if there's a messed up settings I didnt realize. but the issue is still there
    right now I set every setting related to GPU to default, see if there's a miss and to make sure i dont mess up

    Im sorry if Im ranting little bit too much, but this is indeed a major issues, happens to a lot of people who bought the same model as me. issue is the same.
    we're just average costumer who knows little to nothing about IT.
    Last edited by kmkmkmkmkmkm; 07-13-2019 at 11:40 PM.

  4. #4
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    okay to make things more clear

    using monitoring 3rd party hardware like GPU-Z and ROG Gaming Center we can read the clock speed and any activity happens within the CPU and GPU
    so whenever the issue happens, the clock speed at my GPU is reduced to 0-800hz. this is due to GPU switched to power saving mode, which I suspect is a bug where my GPU doesnt know Im running a game. that feature should only happens if Im just idle or browsing with no actual heavy activity

    and since my GPU is "SLEEPING", the GPU is switched to INTEL HD GRAPHICS in order to keep the game running. however as we all know, Intel isnt strong enough, thus the FPS ISSUE HAPPENS

  5. #5
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    5

    Quote Originally Posted by kmkmkmkmkmkm View Post
    ASUS ROG 503GE
    i7-8750H 2.2hz
    Nvidia GTX 1050Ti
    8GB Ram
    256Gb SSD
    1Tb HDD

    Nvidia CP setting is set to default: balanced
    battery settings is set to: max performance

    Nvidia driver is up to date: 431.36
    win 10 is up to date: 1903

    already tried to reset the whole thing, see if there's a messed up settings I didnt realize. but the issue is still there
    right now I set every setting related to GPU to default, see if there's a miss and to make sure i dont mess up

    Im sorry if Im ranting little bit too much, but this is indeed a major issues, happens to a lot of people who bought the same model as me. issue is the same.
    we're just average costumer who knows little to nothing about IT.
    I'm 90% problem is solved if you update your INTEL Graphic driver
    Leave a reply if it worked
    Go for automatic driver detector

  6. #6
    ROG Enthusiast Array FixGX501G's Avatar
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    27

    Hi there! It seems like Nvidia's 431.36 driver is crap. With that driver I've got the mem clock stuck at 200Mhz issue until reboot back again. Resulting in ~20fps where it should be ~140. A warm reboot solves it. The issue was gone for a long time already and came back a week ago or so. That's when Nvidia updated their drivers. I went to nvidia extended driver search and rolled back to version 430.86. Guess what, the issue magically disappeared. I suggest to roll back the Nvidia drivers. From your description it sounds like your issue could also be related to that.

  7. #7
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    Quote Originally Posted by aRonio View Post
    I'm 90% problem is solved if you update your INTEL Graphic driver
    Leave a reply if it worked
    Go for automatic driver detector
    checked. mine is up to date tho
    sorry for late reply, tough week.. thanks for suggesting

  8. #8
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    Quote Originally Posted by FixGX501G View Post
    Hi there! It seems like Nvidia's 431.36 driver is crap. With that driver I've got the mem clock stuck at 200Mhz issue until reboot back again. Resulting in ~20fps where it should be ~140. A warm reboot solves it. The issue was gone for a long time already and came back a week ago or so. That's when Nvidia updated their drivers. I went to nvidia extended driver search and rolled back to version 430.86. Guess what, the issue magically disappeared. I suggest to roll back the Nvidia drivers. From your description it sounds like your issue could also be related to that.
    I think mine is different. my memory clock is normal when Idle or browsing.. just anything than gaming
    its only downclocking when ingame... its just very strange

    I already tried to rerolled it too,, no different

  9. #9
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    here's a screenshot

    Click image for larger version. 

Name:	AA.jpg 
Views:	0 
Size:	448.9 KB 
ID:	81069Click image for larger version. 

Name:	AA.jpg 
Views:	0 
Size:	448.9 KB 
ID:	81069

    the charger is charging properly btw. and the battery is still fine. no energy leak whatsoever

    I seriously want to get my warranty, but i couldnt do it until next Christmas due to my job at the overseas.

    anybody recognize this bug??

  10. #10
    ROG Enthusiast Array FixGX501G's Avatar
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    27

    Still does not sound like a warranty case here. The Perf. Limit = Power means either that your GPU wants to consume more power than the PSU can deliver, or it the app demands more performance than the GPU power limit is set to.

    Try to cycle the Fan Overboost in ASUS Gaming Center a couple of times and set it finally to balanced! Set ASUS Battery Health Charging to balanced. And set windows energy settings (left click on battery symbol right down in the sys tray) to max performance.

    Then please forget that ASUS game center crap to monitor your hardware. Use GPUZ to identify what's exactly going on with your GPU.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •