Results 1 to 3 of 3

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    3

    GTX 1050ti on my new Asus Rog gl503ge not performing upto its full potential

    I bought an Asus ROG GL503GE last month and for the time it performed quite well with games reaching up to 120 fps because of the gtx1050ti. But since a week, I have noticed that all my games now run at 30-40 fps. Earlier I thought maybe this was because I updated the Nvidia driver. So just to be sure I clean installed windows, installed all the drivers and then installed the Nvidia drivers that were given on the official page of my laptop model on the Asus site. But no avail, the games are still laggy. So I decided to do a bit of troubleshooting. I installed afterburner to check the temps and clock speeds. Although the temps are quite fine, I noticed that the GPU doesn't clocks up to 1711 MHz that it used to do earlier, now its always stuck on 1354 MHz and at a temp of 50C. The GPU-z and ROG gaming center showed that the performance is limited by power. I don't know what that means or how to solve it. I am at the end of my wits and thinking maybe to RMA the laptop. Any help or guidance will be highly appreciated.
    PS- I only play when I am plugged on and the CPU temps are fine at 80C when playing.
    Full specs:
    i5-8300H
    Nvidia gtx 1050ti
    8 GB DDR4 RAM
    Windows 10 ver-1903

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •