Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Aug 2018

    Unable to Update Bios

    Sorry if this has been asked before but I couldnt find another post on this

    Running a C7H wifi with a R7 2700x
    Current bios is 2203

    When i try to update the bios using EZ update to 2304 or 2406, I get this error

    "The model of the BIOS image doesn't match the BIOS ROM currently present"

    Any idea.

  2. #2
    ROG Enthusiast Array Falck PC Specs
    Falck PC Specs
    MotherboardCrosshair VI Hero Wi-FI
    ProcessorRyzen 7 1800x
    Memory (part number)32GB G.Skill Flare X @3446 14-14-14-14-22-36-1T
    Graphics Card #1AMD Radeon VII
    Sound CardFiio Q5
    MonitorSamsung C34F791
    Storage #12TB HP EX950 M.2 NVMe
    CPU CoolerDeepCool Captain 360EX
    CaseLian-Li PC-O11 Dynamic
    Power SupplyCorsair AX860
    Keyboard SteelSeries Apex M750
    Mouse SteelSeries Rival 600
    Headset B&W P9
    Mouse Pad SteelSeries QCK Prism
    Headset/Speakers B&W P9/BOSE Companion 5
    OS W10 x64
    Network RouterASUS Lyra
    Accessory #1 Lian-Li O11D-1
    Accessory #2 4 x Noctua NF-S12A PWM Chromax

    Join Date
    Jul 2015

    You made sure you've downloaded the Wi-Fi BIOS?

  3. #3
    New ROGer Array
    Join Date
    Aug 2018

    Yes, even re-flashed the 2203 bios from the same page successfully.

  4. #4
    ROG Guru: Blue Belt Array gupsterg PC Specs
    gupsterg PC Specs
    MotherboardAsus Maximus VII Ranger
    Processori5 4690K
    Memory (part number)HyperX Savage 2400MHz 16GB
    Graphics Card #1Sapphire R9 Fury X (1145/545 Custom ROM)
    MonitorAsus MG279Q
    Storage #1Samsung 840 Evo 250GB
    Storage #2HGST 2TB
    CPU CoolerThermalRight Archon SB-E X2
    CaseSilverstone Temjin 06
    Power SupplyCooler Master V850
    Headset/Speakers HyperX Cloud
    OS Win 7 Pro x64 / Win 10 Pro x64
    gupsterg's Avatar
    Join Date
    Feb 2015

    Use Flashback. Method is outlined in manual and scroll down is in this post.
    Intel Defector AMD Rebel

    TR 1950X - Custom WC - Asus Zenith Extreme Alpha - G.Skill Trident Z 3400MHz C14 QC - RX VEGA 64
    R5 3600 - Custom WC - Asus Crosshair VII Hero Wifi - G.Skill Ripjaws V 3800MHz C16 - Sapphire HD 5850 Toxic

    24/7 OC: i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Sapphire Fury X (1145/545 ~17.7K GS 3DM FS)

  5. #5
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012

    Maybe format pendrive for good measure with diskpart

  6. #6
    ROG Member Array
    Join Date
    Nov 2018

    I had the same problem, which is funny enough as I use the same NTFS USB 3.0 drive for my Bios updates for the exact same mobo since I bought it (8 months now)

    Anyway, although I did the 2501 bios update without problems, I wanted to go back to my most stable build I had with 2203 version cause of some unstable problems I encountered with that version of bios. When I tried with the same method, I received the same error message as you did.

    What it did the trick for me:

    1. I formatted the USB flash to Fat 32 from windows option and I make sure NOT to be a quick format
    2. I copied the Bios in the flash and rename the file into C7HWIFI.CAP
    3. Make sure you insert the flash drive into the USB Bios Flashback Port (you can check which port it is from the manual - the first left USB port as you watch the back of the mobo in case it is vertically installed)
    4. You can either do it by pressing the Bios Update button for like 3 secs OR entering into the Bios as you normally do and set it from there (I did the second option)

    In any case I hope this short guide to help you with your need.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts