Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    1

    Question New ASUS G531GW Laptop Seeing two GPU's and no Screen Backlighting.

    I have a bit of an odd error with my SON's just received Laptop. Out of the box it appeared the laptop was not booting up. We could however see HDD access and keyboard was lighting up etc... So we hooked up an external Monitor and the laptop was indeed working. We completed the initial setup hoping it was a driver error or something. After a couple updates and installs the screen was still not coming on.

    In windows 10 it was showing two displays and what I find odd is it says Internal Generic Monitor is using a Intel UHD 630 as its graphics adapter and the external is using the RTX 2070. I have honestly never seen this before. it was at this time we noticed as a sunlight was casting across the screen the monitor was working but there was no Backlighting.

    Tried to boot into the bios but when in the bios it wouldn't display to the external and I can only see it is in the bios menu by using a flashlight pointed at an angle to screen.

    Part of me wants to remove the base and see if there is a cable loose or something simple but as this is a brand new laptop I am not sure of warranty if I do this and there is something else majorly wrong.

    Anyone ever experience this issue? Bad Laptop or something shake loose in Shipping? Will Contact store we bought it from but they were out of stock and Son would hate to wait for a replacement if it is possible it is just something simple.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •