Results 1 to 3 of 3

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    1

    USB DAC Issue with BIOS Firmware 2406/2501 (Crosshair VII Hero)

    I have a non-WiFi version of the C7H and I have a Creative Sound Blaster X7 Limited Edition USB DAC connected. On BIOS 2306, I have no problems with booting up, but I've tried both 2406/2501 and my computer hangs on the boot logo endlessly until I disconnect the DAC.

    Everything else works fine, it's just a weird problem with this. I've updated all drivers and firmware for everything on my PC.

  2. #2
    ROG Guru: Orange Belt Array xeizo PC Specs
    xeizo PC Specs
    Laptop (Model)HP i7-7500U 16GB 256GB NVMe
    MotherboardAsus Maximus VIII Hero
    Processor6700K
    Memory (part number)32GB HyperX/CorsairLP @ 3200MHz
    Graphics Card #1MSI 1080Ti @ Water
    Sound CardSteinberg UR22
    MonitorAOC 1440p 27" S-PLS
    Storage #1256GB Samsung 950 Pro NVMe
    Storage #22xSSD:s, 4xHDD:s
    CPU CoolerAntec 620 AIO push-pull 2xNidec Gentle Typhoon 1450rpm
    CaseCorsair Carbide 200R
    Power SupplyCooler Master V550S
    Keyboard Logitech G710+ MX Brown (50$ on sale)
    Mouse Steelseries Sensei RAW
    Headset Sennheiser HD600
    Mouse Pad Steelseries, hard
    Headset/Speakers Swissonic ASM5 active studio monitors (thomann.de)
    OS Windows10 preview build 16237
    Network RouterAsus RT-N66U

    Join Date
    Apr 2016
    Reputation
    38
    Posts
    273

    Strange, I use a Steinberg UR22 and it works just as fine as usual with 2501

  3. #3
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    8

    I ordered a Sharkoon Gaming DAC Pro S (USB). I will tell you if i have the same issues when it arrives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •