Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    Rog GL531GV - RTX 2060 Not Primary Graphics Processor

    So I just purchased the new Rog Strix G Series GL531GV laptop with the i7-9750h and RTX2060. After building my last few PCs, this is my first laptop and I have some questions.

    From what I can tell the on-board Intel graphics are being used instead of the RTX card. I tried testing the system using the benchmark on cpu.userbenchmark.com and when the test got to the graphics portion the laptop received a very low score for graphics because the Intel graphics were tested and not the RTX. I went into the device manager and both devices are showing enabled and working properly. Should I just disable the Intel graphics?

    I've also noticed that when I go into the Armoury Crate, I only have the ability to select Windows, Silent, or Balanced mode, and Turbo and Manual are grayed out. Is this normal?

    Am I just completely missing something? Sorry if these are dumb questions, I'm not used to how gaming laptops operate or this Asus software. I've tried searching the forums and web but can't find any info as this laptop is a pretty new model. Appreciate any help you guys can provide.

  2. #2
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    13

    Hey

    You did your test with your laptop unplugged, right?

    Turbo and Manual modes are unavailable to use on battery that's why it's grayed out.

    You were using your dedicated GPU, it's just not using its full potential due to the lack of power aka the power brick. While you could play or do some benchmarking on battery, you're only using about 20% or 30% of your laptop's specs

    Do your benchmarks with Turbo mode enabled and let us know the results

  3. #3
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    Correct, I have only run the laptop on battery thus far. Haven't messed with it plugged in. I'll give it a try and let you know. Thanks for the recommendation.

  4. #4
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    So I connected to wall power and you were right, the other fan settings showed up and it actually automatically switched to Performance mode.

    When I re-ran the benchmark the workstation score went way up, but unfortunately, the gaming (graphics) score did not change. Looking at the log I'm getting the following message.

    "WARN: skipping NVIDEA GeForce RTX 2060 - unable to locate attached display."

    Any thoughts? Is it because I don't have an external monitor hooked up and the laptop panel is still using the Intel graphics?

  5. #5
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    13

    Open up the Nivida Panel, change the primary card to "High Performance - Nvidia RTX 2060" and then click apply.

    Reboot your laptop and try again.

    I'll be waiting for your reply

  6. #6
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    I'll try that when I get home tonight. Out of curiosity, is the system supposed to automatically alternate between Intel and Nvidia depending on what application is being used? I've read some places that it is best to use the Intel for light duty, like web surfing and what not, to save resources.

  7. #7
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    That worked, scores were much better after taking your recommended steps. Thanks! When I go to display properties and device manager, it appears that the laptop screen is still using the Intel graphics, but I guess that's ok. Results below.

    Click image for larger version. 

Name:	Annotation 2019-07-23 210459.jpg 
Views:	0 
Size:	178.5 KB 
ID:	81137

  8. #8
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    13

    You're welcome!

    Glad that it worked out for ya, now you should go back to the same options in Nvidia Panel, under "Global" you should choose back the integrated Intel GPU. And then, next to it there's an "application settings" here you should choose manually the apps that you want it to be used by the dedicated Nvidia GPU and apply it, such as games and benchmarking apps. This will help save resources and power from RTX 2060 and use it where it actually matters. The rest of apps should be fine using your integrated Intel GPU, let the Nvidia one take care of the heavy stuff.

    Also, apps or task manager indicating that the Internal GPU being used is totally normal and that's how it should work as long as the app you're using is not depending 100% on it just like what you experienced earlier.

    Good luck!
    Last edited by SulimanAF; 07-24-2019 at 03:03 AM.

  9. #9
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    One last question. Any idea why after I disable Intel graphics from device manager the Nvidia control panel says there is no Nvidia hardware installed?

  10. #10
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    13

    Quote Originally Posted by Justntyme View Post
    One last question. Any idea why after I disable Intel graphics from device manager the Nvidia control panel says there is no Nvidia hardware installed?
    Because this is the setup on notebooks, both graphics cards depend on each other, specially if your display doesn't support G-SYNC.
    Let it do its thing, don't worry about it

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •