Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    6

    B450-I AMD HDMI Sound Device Dropping or Disappearing

    Hello All,

    I have the Asus ROG Strix B450-I motherboard with an AMD Ryzen 5 2400G. I bought it at the beginning of 2019. Up until now I have had no issues with it. I have it connected to a Denon 2310-CI receiver via HDMI. Within the last week or 2 it seems the AMD High Definition Audio Device has been dropping from Windows 10. I can fire up a browser, start playing a video or any audio. The sound will play for a second or 2 then stop. If I bring up the volume slider and change the volume I hear the tone indicating the volume is changing,so I know audio is passing. However, I see the sound icon in the task tray go to a red circle with a white x, then go back to a speaker icon. If I fire up the sound control panel, I can see it disappear, then reappear periodically. This behavior is very strange to say the least. The event manager shows no errors when this occurs.

    I know I'm reaching here since I don't know how many people have a similar configuration, but has anyone else experienced this behavior?

    I thought it was possibly related to the most recent AMD drivers being installed, but I rolled back the drivers but the problem still persists. I also thought if I updated to the latest BIOS it might help, but it didn't. I think this board may be going bad. I know it's not the receiver because all other inputs are working just fine. I think I might end up just wiping out the whole OS and starting from scratch since it's just a media center PC.

  2. #2
    ROG Enthusiast Array Plan3tCrack3r PC Specs
    Plan3tCrack3r PC Specs
    MotherboardROG STRIX X470-F GAMING
    ProcessorRyzen 2700X
    Memory (part number)Vengeance RGB Pro CMW16GX4M2C3000C15
    Graphics Card #1XFX Fatboy RX 590
    Sound CardPioneer Elite Receiver, SteelSeries GameDAC
    MonitorAcer KG271U 1440p/144Hz, Samsung 46" 1080p
    Storage #1970 EVO 500GB, Inland Premium 256GB NVME, Sandisk Ultra 3D 1TB, 850 EVO 500GB
    Storage #2Barracuda Pro 2TB, Firecuda 2TB
    CPU CoolerH115i Pro, 3X LL120 Fans
    CaseCorsair Obsidian 500D
    Power SupplyThermaltake Toughpower Grand RGB 650 Gold
    Keyboard K70 MK.2 Low Profile Rapidfire - MX Speed, Logitech G613 Wireless
    Mouse SteelSeries Rival 600, G602, MX Anywhere 2S
    Headset SteelSeries Arctis 3 w/ GamDAC
    Mouse Pad SteelSeries Qck Prism Cloth XL
    Headset/Speakers Polk 5.1 Towers, bookshelves, sub
    OS Windows 10 Pro
    Accessory #1 DualShock 4

    Join Date
    Apr 2017
    Reputation
    10
    Posts
    37

    The problem is likely the AMD audio driver that gets updated along with the video driver in Radeon Settings, when a new audio driver is available. I too have had this problem in the past, then it went away a few months back, and is now happening again after the latest video driver update and included audio driver, 10.0.1.12, 7/10/2019. I have a 2700X CPU and RX 590, connected to Pioneer receiver via HDMI, and the audio will cut out due to a STEREO/PCM conflict, usually only at the very start of lets say a youtube video and then resolved after a few clicks in Windows 10.

    1) Right click W10 speaker icon in system tray
    2) Select Speaker setup (xx), which extends menu.
    3) Select Stereo, watch display of external audio receiver
    4) Follow steps1-3, now choose 5.1 or 7.1 or whatever other actual speaker setup you have configured
    5) The audio receiver display should now change from STEREO to PCM or whatever your receiver normally shows for surround mode if the receiver itself has a surround mode selected

    This is the only workaround I have found that gets audio working every time, besides rolling back the audio driver. I haven't found a way to compare AMD package driver versions with currently installed versions in the latest Radeon Settings UI update that started about a month ago. The older version allowed a simple mouse cursor hover over the new driver and a dialog box appeared that compared the installed version with the package version. *See Edit below for correction (19/08/12)

    Edit: When updating the AMD video driver, choosing Custom Install instead of Express Install will allow comparing installed vs new packaged drivers by hovering each driver with the mouse cursor.
    Last edited by Plan3tCrack3r; 08-12-2019 at 05:36 PM. Reason: Added note about AMD video driver custom install
    X470-F, 2700X, RX 590, 970 EVO, Obsidian 500D, H115i Pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •