Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2018

    Can't update Armoury


    I have searched far and wide for a solution, but I haven't found one since I bought my ASUS ROG hardware.

    I have ROG Armoury version 2.06.04, firmware version 1.255, and I have never been able to update it. When I attempt to, through the software itself, I get the message "Please turn off Aura software to unlock Armoury". I have tried closing all related AURA software, even uninstalling it, to no avail. I tried updating Lightning Control to 1.07.71, but nothing changes.

    When I try to update Armoury through the downloaded driver, from the ASUS website, I get the error message "An installation support file could not be installed". I get the same error when trying to uninstall Armoury. It's version 30030 I'm trying to update to.

  2. #2
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011

    the light is normal in order to have control on armory is to un-sync the lights on the peripheral side first in order to enter armory

    that will not change
    Learn, Play Enjoy!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts