Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    1

    Question ASUS ROG GL552VW sudden lagging

    I bought this laptop 2.5 years ago.
    Usually, my laptop is normally working when I used for gaming. It's always lag when I unplugged, but working normally when plugged. Suddenly, my laptop's performance slowing down. I dont even touch any setting before. Usually, I get 60+ fps on Dota 2 on maximum setting when plugged, but now it's below 30 fps even when plugged. All's happened even when I barely turn on my laptop. I'm using Windows 10. Here's what I tried to do to fix it :
    1. Setting "Prefer Maximum Performance" on nVidia Control Panel
    2. Setting "High Performance" on Battery Setting
    3. Reinstall Windows.
    4. Cleaning components from dusts.
    5. Tried using another charger with same model as mine.
    6. Updating Intel HD Graphic's driver and nVidia's driver.
    7. Tried to play without battery.
    Nothing worked so far. So maybe you guys have any idea what's wrong with my laptop?

    <AwesomeBaller69>

  2. #2
    ROG Guru: Orange Belt Array navis995's Avatar
    Join Date
    Oct 2014
    Reputation
    50
    Posts
    320

    Check if your GPU is hitting 3D clocks and not throttling.
    Asus Rog G750JZ
    Screen: 1920x1080 17.3'
    CPU: Intel® Core™ i7-4700HQ (3.4Ghz @ -70mV)
    GPU: GeForce GTX 880M 4GB (OC +125Mhz Core, +600Mhz Memory @ 1.062V)
    RAM: Samsung 32GB 1600MHz
    Storage #1: Samsung Evo 840 250GB
    Storage #2: Samsung Evo 850 500GB
    Storage #3: Seagate Barracuda 2TB
    Storage #4: Samsung Evo 128GB MicroSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •