Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    ROG Enthusiast Array
    Join Date
    Feb 2017
    Reputation
    10
    Posts
    35

    BIOS Version 2605 on B450-F power cycles on restart from Windows.

    BIOS Version 2605 on B450-F power cycles on restart from Windows, so it competently powers off and then on, can we get this fixed in next bios please.

  2. #2
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    6

    Where did you even find that version?, latest bios in the website is 2501.
    I assume you're talking about the rog strix B450-F.

  3. #3
    ROG Enthusiast Array
    Join Date
    Feb 2017
    Reputation
    10
    Posts
    35

    It's not on the global site, it is on the uk Asus site.

  4. #4
    ROG Guru: Blue Belt Array gupsterg PC Specs
    gupsterg PC Specs
    MotherboardAsus Maximus VII Ranger
    Processori5 4690K
    Memory (part number)HyperX Savage 2400MHz 16GB
    Graphics Card #1Sapphire R9 Fury X (1145/545 Custom ROM)
    MonitorAsus MG279Q
    Storage #1Samsung 840 Evo 250GB
    Storage #2HGST 2TB
    CPU CoolerThermalRight Archon SB-E X2
    CaseSilverstone Temjin 06
    Power SupplyCooler Master V850
    Headset/Speakers HyperX Cloud
    OS Win 7 Pro x64 / Win 10 Pro x64
    gupsterg's Avatar
    Join Date
    Feb 2015
    Reputation
    102
    Posts
    982

    Quote Originally Posted by raven77uk View Post
    BIOS Version 2605 on B450-F power cycles on restart from Windows, so it competently powers off and then on, can we get this fixed in next bios please.
    I think this is down to Combo PI 1.0.0.3 Patch AB, as when I use a UEFI with that AGESA on my C7H it does the same as you state.
    Intel Defector AMD Rebel

    TR 1950X - Custom WC - Asus Zenith Extreme Alpha - G.Skill Trident Z 3400MHz C14 QC - RX VEGA 64
    R5 3600 - Custom WC - Asus Crosshair VII Hero Wifi - G.Skill Ripjaws V 3800MHz C16 - Sapphire HD 5850 Toxic

    24/7 OC: i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Sapphire Fury X (1145/545 ~17.7K GS 3DM FS)

  5. #5
    ROG Enthusiast Array
    Join Date
    Feb 2017
    Reputation
    10
    Posts
    35

    Yes AB seems to suck, I have higher temps and less boost in gaming. Light loads like browsing the web sees boost to 4.2Ghz with 1.42v. Compare this to the previous bios where it was hitting 1.38v. Hopefully BB patch will be a good one.

  6. #6
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    6

    Quote Originally Posted by raven77uk View Post
    It's not on the global site, it is on the uk Asus site.
    I see, just downloaded it from there, i'll test it tonight to see if i can make my damn nvme work, hopefully they update the global site soon.

  7. #7
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    4

    Quote Originally Posted by raven77uk View Post
    Yes AB seems to suck, I have higher temps and less boost in gaming. Light loads like browsing the web sees boost to 4.2Ghz with 1.42v. Compare this to the previous bios where it was hitting 1.38v. Hopefully BB patch will be a good one.
    Yeah its worse than the last version....

  8. #8
    New ROGer Array Gamil PC Specs
    Gamil PC Specs
    MotherboardStrix B450-F
    ProcessorRyzen 7 3700x
    Memory (part number)KHX3600C17D4/8GX*2@3600
    Graphics Card #1MSI RX-480 GamingX 8gb OC
    MonitorASUS VP247x2
    Storage #1Samsung 970 EVO+ 500gb
    Storage #2860EVO 250gb/Black 2tb/Barracuda Green 2tb
    CPU CoolerWraith Prism
    CaseNZXT H500
    Power SupplyCorsair RMX650X
    Keyboard Bloody B945
    Mouse ROG Spatha
    Headset HyperX Cloud Revolver
    Headset/Speakers Logitech G51
    OS Windows 10 Pro
    Network RouterRT-AC56U
    Accessory #1 ZS620kl
    Accessory #2 BT400

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    10

    What the hell is wrong with ASUS?

    They release this goddamned BIOS a month late, supposedly because they were "testing" it, with a *known bad AGESA revision*?

    I really don't want to tear down my build just to throw away my ASUS board and get a Gigabyte, but I'm getting to that point.

  9. #9
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Gamil View Post
    What the hell is wrong with ASUS?

    They release this goddamned BIOS a month late, supposedly because they were "testing" it, with a *known bad AGESA revision*?

    I really don't want to tear down my build just to throw away my ASUS board and get a Gigabyte, but I'm getting to that point.
    I cannot boot with fast boot disabled so it won't let me actually get my real performance and I am stuck 1.45v idle again now. This bios sucks.

  10. #10
    New ROGer Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    1

    Here's my report on updating to the 2605 on the ROG B450 F-Gaming with my Ryzen 3600:

    Went pretty smooth, upon reboot, the computer was stuck at a black screen with the red LED light on the motherboard. Required a hard power off/on. But after the the PC powered back on, its been fine restarting normally.

    Voltages/temps and CPU speed seem better. Computer fans are not racing as they were.

    Got into Windows noticed 15.9 usable when 16 Gbs was installed, and I have a discreet GTX 1650. A "Windows Update" run for 1903 did not help.

    This is the first time I have seen 15.9 Gbs of ram listed with a discreet GPU.

    I have had issues with my board going to the black screen/Red LED light before, when I would do driver updates for my hardware. After a hard reset off/on, the PC was fine. It would power on and off just fine. I have never seen this with a ROG Strix board and I attribute it to the immaturity of the Ryzen 3000 CPUs and the buggy BIOS.
    Last edited by Oneliner; 08-14-2019 at 12:37 AM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •