Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Jul 2019


    Hey guys,
    I'm new here and I wanted to get some device because I'm truly in need of help.
    I bought an ASUS Rampage V Extreme as defective for very cheap, and I wanted to attempt a repair on it.
    When I plug the Board in, the "Republic of Gamers" Logo lights up, but the other LEDS don't.
    It doesn't power on, it does nothing. I know 3 causes of these problems, a bad crystal regarding frequency, a bad CMOS Battery or a bad Chipset which must be replaced.
    Do you know how I should proceed with the repair? I got the board for very cheap, and I just wan't to get into repairing that stuff.
    I tried to short the two pins of the Power Supply, the green and black one to start the motherboard manually. It works, but the LEDS still don't light up, and the Error Code Display is 00.
    One area near the chipset is getting hot, but the chipset itself isn't.
    I'd be really thankful for any help I could get, I already tried replacing the CMOS Battery and the PSU is fine too, because it worked on another board without any problems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts