Results 1 to 3 of 3
  1. #1
    ROG Enthusiast Array
    Join Date
    Feb 2019
    Reputation
    29
    Posts
    31

    Memory channel B non functional

    I have an Asus B450 E Gaming motherboard, all bios prior to Ryzen 3000 bios worked fine.

    I had a Ryzen 2600 and a Ryzen 1200 working perfectly.
    I am using the correct dimm slots, A2 and B2...I have checked many times the ram is seated properly.

    I have tested each ram stick on it's own in all 4 dimm slots.
    I am currently on the latest 2605 bios.

    All bios settings set to factory default.
    I have tried to sets of memory now, a 16GB and 32GB kits of G.Skill trident z rgb and a kit of corsair vengeance rgb pro.

    No matter what...no matter the swapping dims around, my B channel is non functional.

    B1 and B2 are not detecting the memory.

    I have power to both B1 and B2...the rgb lights up, but the board will not post.

    If I put the dimms in A1 and A2 the board boots and works as normal.

    But using just the A channel I am running my PC in single channel mode.

    If the B channel was fried the board would not work at all, the fact the B channel is powering the dimms but not posting....this must be a bios level problem....right ?

    Can anyone help ?, is something disabled in bios that should not be ?

    I have hwinfo dumps and I can make a YouTube video if Asus need it.

  2. #2
    ROG Enthusiast Array
    Join Date
    Feb 2019
    Reputation
    29
    Posts
    31

    Btw...in case anyone asks, I have used memtest on both kits. I ha e completed a 4 passes with 0 errors on both the G.Skill and Corsair memory kits.

    The memory itself is fine, this is a board or bios level problem.
    Personally I think it's pure bios, for example...I updated to the 2406 bios, I had a ryzen 2600 installed.

    Memory worked perfectly, I swap out to the ryzen 3600...boom, right away, no post.

    A2 and B2 dumms slots populated...no post, I test each stick in all four dimm slots, B channel non functional.

    But A channel working fine...this MUST be a bios level problem.

  3. #3
    ROG Enthusiast Array
    Join Date
    Feb 2019
    Reputation
    29
    Posts
    31

    Another note...both memory kits have been validated for ryzen I paid extra to get the G.Skill GTZRX kit.

    The Corsair kit is also validated by Corsair to work with ryzen 3000.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •