Results 1 to 3 of 3

Threaded View

  1. #1
    ROG Enthusiast Array
    Join Date
    Feb 2019
    Reputation
    29
    Posts
    30

    Memory channel B non functional

    I have an Asus B450 E Gaming motherboard, all bios prior to Ryzen 3000 bios worked fine.

    I had a Ryzen 2600 and a Ryzen 1200 working perfectly.
    I am using the correct dimm slots, A2 and B2...I have checked many times the ram is seated properly.

    I have tested each ram stick on it's own in all 4 dimm slots.
    I am currently on the latest 2605 bios.

    All bios settings set to factory default.
    I have tried to sets of memory now, a 16GB and 32GB kits of G.Skill trident z rgb and a kit of corsair vengeance rgb pro.

    No matter what...no matter the swapping dims around, my B channel is non functional.

    B1 and B2 are not detecting the memory.

    I have power to both B1 and B2...the rgb lights up, but the board will not post.

    If I put the dimms in A1 and A2 the board boots and works as normal.

    But using just the A channel I am running my PC in single channel mode.

    If the B channel was fried the board would not work at all, the fact the B channel is powering the dimms but not posting....this must be a bios level problem....right ?

    Can anyone help ?, is something disabled in bios that should not be ?

    I have hwinfo dumps and I can make a YouTube video if Asus need it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •