Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    [GL504GW] Bios version 305

    GL504GW's bios version 305 has been released today. Do we know anything more than "Improve System Stability" written on the changelog?

  2. #2
    ROG Enthusiast Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    29

    before you update do a cinebench r15 test on cpu, and then repeat it after bios update.

    Is the only way to see if something has changed, over than fan curves or other minor things

  3. #3
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    I don't really know why and how, but my Windows Update automatically downloaded and installed this bios version. Never happened before. And it's kinda scary. I should be in charge of deciding whether or not to update.

  4. #4
    ROG Enthusiast Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    29

    yes, windows update by a couple of month on some pc's update even bios... today my rog 704gw updated to 308. cinebench scores are the same, such as vbios version, so i really don't know waht they changed...

  5. #5
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    20

    Pushing the BIOS update through Windows Update is scary, those who installed could you please confirm if the Manual mode in the Armoury Crate still works when you set the fans to 100% it actually runs at full speed or did they change it back to work the same as Turbo mode no matter what % you choose?

    by the way, for those who want to avoid updating can actually do it using Microsoft's “Show or Hide Updates” troubleshooter to hide the update from here

  6. #6
    ROG Enthusiast Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    29

    Quote Originally Posted by SulimanAF View Post
    Pushing the BIOS update through Windows Update is scary, those who installed could you please confirm if the Manual mode in the Armoury Crate still works when you set the fans to 100% it actually runs at full speed or did they change it back to work the same as Turbo mode no matter what % you choose?

    by the way, for those who want to avoid updating can actually do it using Microsoft's “Show or Hide Updates” troubleshooter to hide the update from here
    yes, manual mode work as it should...

  7. #7
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    20

    Quote Originally Posted by gieffe22 View Post
    yes, manual mode work as it should...
    Thanks a lot, that's a relief : )

  8. #8
    ROG Guru: White Belt Array
    Join Date
    Jul 2013
    Reputation
    11
    Posts
    113

    Well just turned in my computer and was greeted with a bios update :/

    Idk what is the changelog

  9. #9
    New ROGer Array SulimanAF's Avatar
    Join Date
    Jun 2019
    Reputation
    11
    Posts
    20

    Quote Originally Posted by TX2000 View Post
    Well just turned in my computer and was greeted with a bios update :/

    Idk what is the changelog
    Let us know if you noticed anything different, thanks.

  10. #10
    ROG Enthusiast Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    29

    anyway i played some games and a bit a heavy photoediting, temperatures and performance honestly feels the same, Cinebench have the same score, such as unigine heaven and benchmarks from some games...so i think is just bug fix or the usual fixes from intel

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •