Results 1 to 3 of 3
  1. #1
    ROG Enthusiast Array
    Join Date
    Jan 2019

    Audio Driver for X399 AZE Alpha


    It seem i have issue with driver for sound card on this board.
    I'm getting all the time cannot connect to RPC service when pulling Realtek audio console.

    I tried reinstalling drvier from page multiple time with same result.

    Also Sound Studio does not work


  2. #2
    ROG Member Array EviLFazZ PC Specs
    EviLFazZ PC Specs
    MotherboardROG Zenith Extreme Alpha X399
    ProcessorAMD Ryzen 2950X
    Memory (part number)G.Skill DDR4 4x 8GB 3600MHz
    Graphics Card #1EVGA 2080Ti Ti FTW3 Ultra
    Sound CardAsus Xonar HD1.3 with daughter board
    MonitorLG 31MU97Z-B
    Storage #1Samsung 960 EVO 256GB
    Storage #2Samsung 840 PRO 256GB
    CPU CoolerCorsair AiO H110i v2
    CaseCoolmaster Cosmos (original)
    Power SupplyCorsair HX1000i
    Keyboard Corsair K95 RGB (Edition 3)
    Mouse Logitech MX Ergo Trackball (Plus Edition)
    Headset AKG K812 Pro and Sennheiser HD 380 Pro
    Mouse Pad The table, one of our cats, my lap, the floor, my sexy other, etc
    Headset/Speakers Mission; Floor-standers, Bookshelves, Dipoles and Centres, and two REL Subwoofers
    OS Windows, Ubuntu and Steam OS
    Network RouterTP-Link AC5400
    Accessory #1 Valve Index
    Accessory #2 8x Steam Controllers
    Accessory #3 Logitech Brio WebCamera

    Join Date
    Nov 2017

    Same here and for weeks since I purchased it

    I kinda regret upgrading to this board from the original (non-Alpha) and the support (like all things Asus) is just awful (again)... with old broken drivers listed on the official support page, older/broken AMD drivers still being listed, current ones breaking or as you said, do not even work, let alone the Realtek Control Panel, which has now been pushed to the Windows Store and does not even download, let alone work

  3. #3
    ROG Enthusiast Array
    Join Date
    Jan 2019

    so which one we shall use for latest windows to make it work with advertised SS for this mobo?

    UAD/HDA .. with RAC or SS ?

    I'm competly lost..

    I tried most of configuration and RAC and SS does not work with this mobo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts