Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    2

    GL703VM - ROG Gaming Center no longer works after windows reinstall

    I switched out the SSD in my GL703VM so naturally lost all drivers preinstalled on the previous one that came with the laptop.
    Now after a clean Windows 10 install and manually installing ROG Gaming Center, it no longer works - it's not bound to the ROG button, it doesn't detect the GPU/CPU temperature, the touchpad on/off function doesn't work, etc.
    I tried 2.1.5 which I found as latest on the ASUS ROG website, and 2.6.1 which I found linked somewhere here in the forums. No luck.

    What driver am I missing? Or what may be the problem?

    Thank you in advance for your help!

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    91

    I think the ATK Package V1.0.0060 will be missing.
    I give you the download link https://dlcdnets.asus.com/pub/ASUS/G...64_V100060.zip

    Chipset, audio, Intel MEI etc gets my ASUS notebook via the Windows update.

    Also try to do all windows updates and look in the device manager if devices were not detected. (yellow question mark)

    I hope it will help. Best regards TOM
    Last edited by Tom Tromboni; 09-09-2019 at 06:50 PM.

  3. #3
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    2

    That was it. Now it works perfectly.

    Thank you very much for the quick answer!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •