Results 1 to 5 of 5
  1. #1
    New ROGer Array sturm375 PC Specs
    sturm375 PC Specs
    MotherboardRampage VI Extreme Omega
    Processori9-9900x
    Memory (part number)Corsair CMK32GX4M4A2666C16 64 GB
    Graphics Card #1EVGA GTX 1080
    Graphics Card #2EVGA GTX 1050
    Monitor2x Dell Ultrasharp 24" 1920x1200
    Storage #12x Samsung EVO 970 500GB
    Storage #22x Samsung QVO 860 2TB
    CPU CoolerCorsair H150i
    CasePhanteks Eclipse P600s
    Power SupplyCorsair RM100x
    Keyboard Steelseries Apex 750
    Mouse Logitech Trackman Wireless
    OS Win10 Pro
    Network RouterNetgear Nighthawk AX8000
    sturm375's Avatar
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    5

    (Solved)ROG Rampage Extreme Omeaga no post only clicks

    Hi folks,

    Hope you can help me. Putting to gather a new PC with a new ROG Rampage VI Extreme Omega. On my first attempt at firing it up, the RGB lights would light up on the Mobo, and the LED screen on the Mobo would work. Whether I use the power button on the case, or the button on the mobo itself, I gete a few clicks as it tries to fire up, then nothing. None of the case fans light up. The Corsair AIO pump does not start up. I get no post, and once I try it then I no longer get those clicks when I use a power button. I've checked all the connections to the power supply. That power supply is a Corsair AX1200. I've removed everything I can think of to eliminate issues. It just will not post Could possibly be the mobo itself, though I hope not, I do not want to go through an RMA if I don't have to. GOing out to grab a new PSU and try that, but I am not hopful.

  2. #2
    New ROGer Array sturm375 PC Specs
    sturm375 PC Specs
    MotherboardRampage VI Extreme Omega
    Processori9-9900x
    Memory (part number)Corsair CMK32GX4M4A2666C16 64 GB
    Graphics Card #1EVGA GTX 1080
    Graphics Card #2EVGA GTX 1050
    Monitor2x Dell Ultrasharp 24" 1920x1200
    Storage #12x Samsung EVO 970 500GB
    Storage #22x Samsung QVO 860 2TB
    CPU CoolerCorsair H150i
    CasePhanteks Eclipse P600s
    Power SupplyCorsair RM100x
    Keyboard Steelseries Apex 750
    Mouse Logitech Trackman Wireless
    OS Win10 Pro
    Network RouterNetgear Nighthawk AX8000
    sturm375's Avatar
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    5

    SOLVED!


    Turns out the Corsair AX1200 though it has enough power, it does not have the right cabling. New Corsair RM1000x solved the issue.

  3. #3
    ROG Guru: Green Belt Array UltraNEO* PC Specs
    UltraNEO* PC Specs
    Laptop (Model)Dell XPS 13
    MotherboardAsus Rampage V Edition 10
    ProcessorIntel i7-6850k
    Memory (part number)G.SKILL F4-3600C17Q-32GTZR
    Graphics Card #1Titan X (Pascal)
    Graphics Card #2Titan X (Pascal)
    MonitorASUS ROG Swift PG279Q (x3)
    Storage #1Samsung 970 Pro 1TB NVMe
    Storage #2Samsung 860 Pro 1Tb (x4)
    CPU CoolerCustom Watercooled
    CaseCaseLabs SMA8
    Power SupplyCorsair AX1500i
    Keyboard Keyboard Paradise Custom
    Mouse Logitech G903
    Mouse Pad Logitech G840 XL
    Headset/Speakers ART SLA2 Linear Amp with JBL Control 5
    OS Win 10 Pro
    Network RouterPF Sense
    Accessory #1 Logitech Brio 4k
    Accessory #2 Logitech PowerPlay Game Pad
    UltraNEO*'s Avatar
    Join Date
    Dec 2011
    Reputation
    48
    Posts
    591

    Quote Originally Posted by sturm375 View Post
    SOLVED!


    Turns out the Corsair AX1200 though it has enough power, it does not have the right cabling. New Corsair RM1000x solved the issue.
    Strange... I have an AX1200i on my system and two RTX 2080 Ti's Not had any issues with posting in regards of the Omega.
    ASUS ROG RVIE Omega | i9-9980xe | Dominator Platinum 128GB 3333 MHz | EVGA RTX 2080 Ti SLI | Samsung 970 Pro 1TB NVMe (x3)
    WD Black 4TB x2 | WD Black 6TB | Corsair AX1200i | CaseLabs SMA8 | Custom Water Cooling | HWLabs Black Ice Nemesis GTX 560
    XSPC RX 480 v3 | XSPC D5 Vario x2 | EK Blocks | EK-RES X3 400 | BitsPower Fittings | GentleTypoon 1850 x12 | Corsair SP140 x8 | Lamptron CM615

    Twitch.tv/MsNikita | Twitter.com/MsNikitaTV | Instagram.com/MsNikitaTV | Reddit.com/r/MsNikitaTV

  4. #4
    New ROGer Array sturm375 PC Specs
    sturm375 PC Specs
    MotherboardRampage VI Extreme Omega
    Processori9-9900x
    Memory (part number)Corsair CMK32GX4M4A2666C16 64 GB
    Graphics Card #1EVGA GTX 1080
    Graphics Card #2EVGA GTX 1050
    Monitor2x Dell Ultrasharp 24" 1920x1200
    Storage #12x Samsung EVO 970 500GB
    Storage #22x Samsung QVO 860 2TB
    CPU CoolerCorsair H150i
    CasePhanteks Eclipse P600s
    Power SupplyCorsair RM100x
    Keyboard Steelseries Apex 750
    Mouse Logitech Trackman Wireless
    OS Win10 Pro
    Network RouterNetgear Nighthawk AX8000
    sturm375's Avatar
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    5

    Quote Originally Posted by UltraNEO* View Post
    Strange... I have an AX1200i on my system and two RTX 2080 Ti's Not had any issues with posting in regards of the Omega.
    Not suprised. AX1200i will have different outputs than my older AX1200 (no "i").

  5. #5
    ROG Guru: Green Belt Array UltraNEO* PC Specs
    UltraNEO* PC Specs
    Laptop (Model)Dell XPS 13
    MotherboardAsus Rampage V Edition 10
    ProcessorIntel i7-6850k
    Memory (part number)G.SKILL F4-3600C17Q-32GTZR
    Graphics Card #1Titan X (Pascal)
    Graphics Card #2Titan X (Pascal)
    MonitorASUS ROG Swift PG279Q (x3)
    Storage #1Samsung 970 Pro 1TB NVMe
    Storage #2Samsung 860 Pro 1Tb (x4)
    CPU CoolerCustom Watercooled
    CaseCaseLabs SMA8
    Power SupplyCorsair AX1500i
    Keyboard Keyboard Paradise Custom
    Mouse Logitech G903
    Mouse Pad Logitech G840 XL
    Headset/Speakers ART SLA2 Linear Amp with JBL Control 5
    OS Win 10 Pro
    Network RouterPF Sense
    Accessory #1 Logitech Brio 4k
    Accessory #2 Logitech PowerPlay Game Pad
    UltraNEO*'s Avatar
    Join Date
    Dec 2011
    Reputation
    48
    Posts
    591

    Quote Originally Posted by sturm375 View Post
    Not suprised. AX1200i will have different outputs than my older AX1200 (no "i").
    Well glad you resolved it
    ASUS ROG RVIE Omega | i9-9980xe | Dominator Platinum 128GB 3333 MHz | EVGA RTX 2080 Ti SLI | Samsung 970 Pro 1TB NVMe (x3)
    WD Black 4TB x2 | WD Black 6TB | Corsair AX1200i | CaseLabs SMA8 | Custom Water Cooling | HWLabs Black Ice Nemesis GTX 560
    XSPC RX 480 v3 | XSPC D5 Vario x2 | EK Blocks | EK-RES X3 400 | BitsPower Fittings | GentleTypoon 1850 x12 | Corsair SP140 x8 | Lamptron CM615

    Twitch.tv/MsNikita | Twitter.com/MsNikitaTV | Instagram.com/MsNikitaTV | Reddit.com/r/MsNikitaTV

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •