Results 1 to 2 of 2

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    2

    Unhappy Screen goes blank for a second on bootup GL504GW

    Hello everyone, this is my first post, so please go easy on me.

    Every time I boot up, after I enter my password and when I can see the desktop, the screen goes black for a second or two( And then comes back on like nothing happened). This seems more likely to happen when the power is not connected. I did not find any solutions to this particular problem online. So does anyone here have a solution?

    I have another question. Is it okay that my new laptop has a slight lag (Keeping in mind the specifications that should actually make this machine a beast)? I wouldn't call it lag as such but it can surely be faster when maybe starting up the Windows explorer. The lag is present for sure when I try to fullscreen videos on YouTube. It takes almost 2 seconds to go into fullscreen and come out of it.
    I am thinking that I should reset Windows. Because I have faced other bugs too on this new laptop. But I am in a dilemma about resetting windows because I have read in other forums that I would lose certain performance customisations from ASUS. I have noticed a ton of services from ASUS that is running on my PC and I am not sure if they are increasing the performance or just being bloatware. So please advice.

    Thank You

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •