Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    4

    Strix-X570-F thinks my Bios is up to date

    Motherboard:Strix-X570-F
    Bios:7010
    CPU:3700x
    GPU:Asus 5700x
    OS: Windows10 pro

    My Strix-X570-F seems to think that my Bios (ver. 7010) is up to date.
    When I built this PC I updated the Bios using the USB Flashback button and it worked great.
    This time the flashing light turned solid immediatly so I resorted to the normal method within the Bios, but the MB told me I was up to date even though there are 2 newer versions...
    Version 1005 --- 2019/08/12
    Version 1201 --- 2019/09/12
    found here...
    https://www.asus.com/us/Motherboards...Desk_Download/

    Should I be worried?
    Miniatura de Adjuntos Miniatura de Adjuntos Cpu-z.jpg  


  2. #2
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    4

    Don't be into much of a hurry

    Don't be in too much a hurry on the 1201...It seems to have blown up my board, and I can't seem to get flashback to work.

    Get a Beep, Get a Post screen "Hit F2 or DEL...blah blah" But it never starts loading the OS and no matter how much I hammer the keys I can't get the BIOS config to load. Shorting the CMOS clear, does nothing, Flash back blinks 3 times, I see the light on the USB blink a couple times...then the light is out...nothing...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •