Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Apr 2018

    ROG Gaming Centre not starting

    So, out of the blue the ROG gaming centre no longer works on my GL702V. The one that came with the laptop CtD'd when i tried to alter the fans. I installed the latest version and that won't load at all. I have W10 1903 18362.356. Only thing i think that changed between when it last worked and now was a driver update.
    Failing getting it working again, how else can I change fan speed on my laptop?
    Oh, and Intel Extreme Tuning Utility started reporting that there was something else similar to it running when there wasn't. Different issue but happend at the same time.

  2. #2
    ROG Guru: Yellow Belt Array Dimitrios1971 PC Specs
    Dimitrios1971 PC Specs
    Laptop (Model)GX700VO 1TB SSD + 64GB RAM
    ProcessorAMD Ryzen Threadripper 2950X
    Memory (part number)F4-4000C18Q2-64TZR (3333MHz)
    Graphics Card #1ROG Strix GeForce® GTX 1080 Ti OC-Edition
    MonitorROG Swift PG348Q Gaming
    Storage #14 x Samsung SSD NVMe 960 PRO 1TB Raid0
    Storage #24 x Samsung SSD NVMe 970 PRO 1TB Raid0
    CPU CoolerCOOLER MASTER MasterLiquid ML360 RGB TR4 Edition
    CaseROG Strix Helios
    Power SupplyASUS ROG THOR 1200P
    Keyboard ROG Strix Scope Deluxe & ROG Strix Scope TKL Deluxe
    Mouse 2 x ROG Chakram
    Headset ROG Throne Qi
    Mouse Pad ROG Balteus Qi RGB & ROG Sheath
    Headset/Speakers 1 x ROG Strix Go 2.4 & ROG Strix Wireless
    OS Win10_x64
    Network RouterFRITZ!Box 6660 Cable
    Accessory #1 BW-16D1H-U PRO
    Accessory #2 ROG STRIX ARION & Asustor AS6404T
    Accessory #3 2 x HYPER M.2 X16 GEN 4 CARD
    Dimitrios1971's Avatar
    Join Date
    Apr 2015

    hi do you have the gaming center 2.6.1? Then you also need the new bios? if not the problem can be

  3. #3
    ROG Guru: Yellow Belt Array tap002 PC Specs
    tap002 PC Specs
    Laptop (Model)ROG Strix GL703GE-IS74
    MotherboardASUSTeK COMPUTER INC. GL703GE
    Processori7-8750H CPU @ 2.20GHz
    Memory (part number)16GB DDR4 2666MHz DRAM
    Graphics Card #1GTX 1050i
    Storage #1MICRON 1100_MTFDDAV256TBN
    tap002's Avatar
    Join Date
    May 2018

    Hot Key Fn+f5 will control fans. Version 2.6.1 and latest bios should solve your problem. Sometimes XTU and gaming center will conflict with each other. I'm sorry I can't remember which order I installed them. Uninstall both and reinstall. If gaming center during installation asks if you want to install driver; click NO then it will use XTU and both will run fine. (if I remember right) win10 1903 18362.295

  4. #4
    ROG Member Array
    Join Date
    Apr 2018

    Thanks for your replies.
    Gaming Centre is 2.14 I believe. FN + F5 changes screen brightness not fans (I don't see a fan control option on my GL702V). I can update the bios, I guess. Can I use WinFlash for this?
    No idea why it went wrong in first place. Also, as I have deleted ROG gaming centre XTU is working.
    Sorry, it is 2.6.1. I installed an earlier version 2.0.3 and it runs but crashes when I try to change fan speed.
    Last edited by Dreano; 09-21-2019 at 07:39 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts