Results 1 to 5 of 5
  1. #1
    ROG Enthusiast Array Ken429 PC Specs
    Ken429 PC Specs
    Laptop (Model)Toshiba
    MotherboardROG Hero VII WI-FI
    Processor2700X
    Memory (part number)G.Skill (F4-3200C-14D-16GFX)
    Graphics Card #1EVGA GTX 1070 SC
    Sound CardOnboard
    MonitorSamsung 36" UHD
    Storage #1Saamsung 970 500GB
    Storage #2Sandisk Extreme 256GB
    CPU CoolerEVGA CLC 280
    CaseCorsair 750D
    Power SupplySeasonic 1250XM
    Keyboard Microsoft Sidewinder X4
    Mouse Logitech M510
    OS Windows 10 1903
    Network RouterTP-Link AC1200
    Accessory #1 TP-Link SG 1016 Switch
    Accessory #2 Arris SBV 3202

    Join Date
    Jul 2014
    Reputation
    10
    Posts
    42

    Lost Pstates Stuff in BIOS 2703

    Hero VII BIOS 2703 Pstates gone?
    Just updated my ROG Crosshair VII Hero motherboard from BIOS version 2501 to 2703. For some reason the Custom Pstates/Throttling stuff is no longer available under Advanced>AMD CMS in the BIOS. Is there some magic I need to be aware of to get this to show or has it been eliminated somewhere in the last two or three BIOS updates that I missed? Help appreciated.

  2. #2
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    64

    Quote Originally Posted by Ken429 View Post
    Hero VII BIOS 2703 Pstates gone?
    Just updated my ROG Crosshair VII Hero motherboard from BIOS version 2501 to 2703. For some reason the Custom Pstates/Throttling stuff is no longer available under Advanced>AMD CMS in the BIOS. Is there some magic I need to be aware of to get this to show or has it been eliminated somewhere in the last two or three BIOS updates that I missed? Help appreciated.
    That's an old bios now, 2801 just came out a few days ago. I suggest you install that one.

  3. #3
    New ROGer Array RSFoxx PC Specs
    RSFoxx PC Specs
    MotherboardAsus Crosshair VII Hero
    ProcessorAMD Ryzen 3700x
    Memory (part number)F4-3200C14-8GTZN
    Graphics Card #1Asus ROG Strix RTX 2080 OC
    Storage #1Samsung EVO 970 NVMe M.2 256GB
    Storage #2Crucial MX500 2TB
    CPU CoolerCorsair H115i Hydro Pro
    CaseNZXT H700
    Power SupplySeaSonic Focus 750w 80+ Platinum
    Keyboard Corsair Strafe MK.2 Silent
    Mouse Corsair Glaive RGB
    Headset Corsair Void Pro
    OS Windows 10
    Accessory #1 Audio-Technica AT2020 Microphone

    Join Date
    Aug 2019
    Reputation
    10
    Posts
    13

    Quote Originally Posted by TechyInAZ View Post
    That's an old bios now, 2801 just came out a few days ago. I suggest you install that one.
    +1

    2703 was probably the most buggy bios released. 2801 is my favorite so far next to 2501.

  4. #4
    ROG Enthusiast Array Ken429 PC Specs
    Ken429 PC Specs
    Laptop (Model)Toshiba
    MotherboardROG Hero VII WI-FI
    Processor2700X
    Memory (part number)G.Skill (F4-3200C-14D-16GFX)
    Graphics Card #1EVGA GTX 1070 SC
    Sound CardOnboard
    MonitorSamsung 36" UHD
    Storage #1Saamsung 970 500GB
    Storage #2Sandisk Extreme 256GB
    CPU CoolerEVGA CLC 280
    CaseCorsair 750D
    Power SupplySeasonic 1250XM
    Keyboard Microsoft Sidewinder X4
    Mouse Logitech M510
    OS Windows 10 1903
    Network RouterTP-Link AC1200
    Accessory #1 TP-Link SG 1016 Switch
    Accessory #2 Arris SBV 3202

    Join Date
    Jul 2014
    Reputation
    10
    Posts
    42

    I'm missing something! Pstates settings will not show in the BIOS. It ain't the BIOS since I've got the same problem with 2801 that I had with 2703. Back in 2501 it all worked as advertised. Can someone please clue me in on what the heck I'm doing wrong or what changed with the newer BiOS's. I've tried clearing the BiOS and reloading the Defaults but it has on effect - I can't find the Pstates. I'm sure it's something stupid but...help appreciated.
    Miniatura de Adjuntos Miniatura de Adjuntos 190924031147.jpg  

    190924030857.jpg  


  5. #5
    ROG Enthusiast Array Ken429 PC Specs
    Ken429 PC Specs
    Laptop (Model)Toshiba
    MotherboardROG Hero VII WI-FI
    Processor2700X
    Memory (part number)G.Skill (F4-3200C-14D-16GFX)
    Graphics Card #1EVGA GTX 1070 SC
    Sound CardOnboard
    MonitorSamsung 36" UHD
    Storage #1Saamsung 970 500GB
    Storage #2Sandisk Extreme 256GB
    CPU CoolerEVGA CLC 280
    CaseCorsair 750D
    Power SupplySeasonic 1250XM
    Keyboard Microsoft Sidewinder X4
    Mouse Logitech M510
    OS Windows 10 1903
    Network RouterTP-Link AC1200
    Accessory #1 TP-Link SG 1016 Switch
    Accessory #2 Arris SBV 3202

    Join Date
    Jul 2014
    Reputation
    10
    Posts
    42

    What else do I need to do to get some help with the "Missing" Pstates problem I'm having with the C7H MB? Did they get moved to another location in the BIOS?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •