Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Sep 2019

    Realbench OpenCL ERROR: clGetPlatformIDs

    Just tried Realbench on my brand new AMD Ryzen 7 3700X system and it consistently gives an error:

    KSamples/sec: OpenCL ERROR: clGetPlatformIDs(-1001)

    Any ideas?


    CPU:AMD K17 - Speed:3592.7 MHz - Multi:36.0 - Bus:99.8 MHz
    RAM: - 16GB -
    MB: - FW:P3.10 -
    OS:Windows 10 Home
    GPU1:NVIDIA GeForce GTX 1660

  2. #2
    ROG Member Array phantom101 PC Specs
    phantom101 PC Specs
    MotherboardAsus Rampage Extreme V
    Memory (part number)16GB Corsair Dominator DDR4
    Graphics Card #1Nividia 1080
    Sound CardOn Board Supreme FX
    MonitorAsus VES78 / Hp 2205
    Storage #1Samsung 950 Pro M.2
    Storage #2WD Black 2TB
    CPU CoolerCorsair Hydro Series H100i Water Cooler
    CaseCorsair (Xidax) Annihilator
    Power SupplyCorsair RM850
    Keyboard Razor Blackwidow Chroma
    Mouse Razor Deathadder Chroma
    Mouse Pad Razor
    OS Windows 10 Pro 64-bit
    Network RouterLinksys
    phantom101's Avatar
    Join Date
    Jul 2016

    Try this as it worked for me. Make sure you have a copy of OpenCL.dll in C:\Windows\system32. If not, follow the instructions below to see if you have one locally.

    Basically, do a search for OpenCL.dll in C:\, hopefully you'll see at least one match in the driver directory or even in oldwindows dirs, if so, just copy one from the driver directory and past it into the C:\Windows\system32 and you should be good to go. I picked one that had 4 - 500K size.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts