Results 1 to 1 of 1
  1. #1
    New ROGer Array BladeAlchemy PC Specs
    BladeAlchemy PC Specs
    MotherboardAsrock X470 Taichi
    ProcessorRyzen 5 2600
    Memory (part number)4 x 8 Trident Z 3000 cl16
    Graphics Card #1MSI Vega 56 Air Boost OC
    Storage #1XPG Gammix 256gb NVME M.2
    CPU CoolerROG Ryuo 240 AIO
    CasedarkFlash Phantom
    Power SupplyEVGA G3 850
    Keyboard GSkill Ripjaws
    Mouse Logitech G502
    Headset Logitech G633
    OS Win10
    BladeAlchemy's Avatar
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    1

    Exclamation Ryuo 240 connection issue

    Just picked up a Ryuo 240 AIO off a friend who upgraded to a ryujin, it worked fine when he removed it from his rig. I got around to installing it today. The issue is that if the micro usb cable is connected my pc goes insane connecting and disconnecting with the Ryuo. There is an image stored on the drive, and I was able to get live dash to recognize it for a couple seconds. If I unplug the usb cable it runs fine, sans the oled image. Is there anyway to get it to wipe the drive with out having it connected? Like a factory reset?

    I just want full functionality of the AIO, and any help would be greatly appreciated. TIA!

    X470 Taichi
    Ryzen 5 2600
    MSI Vega 56 Air Boost OC
    4 X 8 GSKILL Trident Z RGB 3000 DDR4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •