Results 1 to 10 of 15

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    13

    Nvme drive and long (cold) boot times

    I had this problem before and I can't remember how I fixed it.
    Bios doesn't recognize ("see") my nvme drive samsung 970 evo 256gb (232), but apart from that it's working seemingly without issues, except for the long ass boot times, obviously.

    Motherboard: Crosshair VII hero (bios 2801 - the latest, reinstalled it just earlier today coming from the 2703 trying to fix this issue).
    windows 10, also fresh reinstall (today -- and I secure erased that very drive, so even the bios itself can 'do stuff' to it, even when it doesn't display it anywhere else), so don't even start saying hardware issues or failing drive, I do remember this was often erroneously brought up, from when I fixed this very problem before. I can see the drive in windows disk management, I can see it in gparted (dual boot), I can do stuff with it and I'm posting from an OS freshly installed to it. Also checked firmware which was already up-to-date. I also already learned that some options related to nvme management were removed from newer bioses, but I can't see it listed even among the installed/available drives when I bring up the bios normie mode (ez), for instance -- and if my memory doesn't fail this was the main sympton of my problems (long boot times). CSM, fast boot, secure boot, I've always had them all disabled, and triple checked it all trying to address this.

    Which reminds me that searching for this, I came upon the advice to erase secure boot keys. And I kinda messed up (or not, it removed older entries from the boot menu, which where kinda annoying me anyway), but now I can't bring up the boot options (f8) for this very fresh windows install, and I think this is also related to the fact that the bios can't see the nvme drive (i.e, it doesn't register/save the new secure boot key (yes, I enabled it once trying to verify this, it's already disabled again). Thankfully I did my dual boot correctly and I only start ubuntu from that menu, which otherwise defaults to an windows auto-start.

    tl;dr
    bios doesn't see my nvme ssd
    problem: long boot times

    Click image for larger version. 

Name:	Untitledfgjtyjuykuilsdgverg.jpg 
Views:	0 
Size:	150.4 KB 
ID:	82106

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •