Results 1 to 8 of 8
  1. #1
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    1

    Tuf x570 laggy bios navigation

    I get very laggy performance inside the bios. Mouse movement feels very sluggish and unresponsive, sometimes having to click something a few times for it to register. Nothing wrong with mouse either, works perfect in Windows. It's a wired Logitech G203 so it's not a wireless interference issue.

    I came from an Asus z87 Pro board with basically the same layout and it was very snappy and fast.

    Does anyone know what could be going on? I've updated to latest 1201 bios too.

  2. #2
    ROG Member Array ITAngel PC Specs
    ITAngel PC Specs
    Laptop (Model)GL502VS-DB71
    MotherboardASUS ROG Crosshair VIII HERO
    ProcessorAMD RYZEN 7 3700X 8-Core 3.6 GHz
    Memory (part number)CMT64GX4M4C3200C16
    Graphics Card #1EVGA GeForce RTX 2080 SUPER XC ULTRA GAMING
    Sound CardASUS SupremeFX S1220 CODEC
    MonitorSAMSUNG 27" CHG70 Gaming Quantum Dot
    Storage #1SAMSUNG 970 500GB M.2 NVME
    Storage #2SAMSUNG 970 256GB M.2 NVME
    CPU Coolerbequiet! DARK ROCK TF 220W TDP
    CaseCORSAIR 680X (8-Corsair LL120 RGB Fans)
    Power SupplyCORSAIR RMx Series RM850x Gold
    Keyboard CORSAIR K95 RGB PLATINUM XT
    Mouse CORSAIR IRONCLAW RGB Wireless
    Headset SteelSeries Arctis Pro Wireless + DAC
    Mouse Pad Logitech G440 Hard Gaming Mouse Pad
    Headset/Speakers Klipsch ProMedia 2.1 THX Certified Computer Speaker System
    OS Windows 10 Pro 64bit
    Network RouterNETGEAR - Orbi AC2200 Tri-Band Mesh
    Accessory #1 Klipsch ProMedia 2.1 THX
    Accessory #2 CORSAIR ST100 RGB Premium Headset Stand
    Accessory #3 Microsoft Xbox Wireless Controller - White

    Join Date
    Sep 2014
    Reputation
    10
    Posts
    11

    I am having the same issue with the Tuf x570 laggy bios navigation before and after bios update.

  3. #3
    New ROGer Array BenLomax PC Specs
    BenLomax PC Specs
    MotherboardTUF GAMING x570-PLUS
    ProcessorRyzen 3 3700x
    Memory (part number)Gskill Trend Z RGB
    Graphics Card #1RTX 270

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    3

    Hey,

    Same here, laggy bios navigation - checked on 1201 and 1202.

    Any feedback?

    Regards.

  4. #4
    ROG Junior Member Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    1

    Thought it was just me I'm having the same issue. Are there any beta bios for this board?

  5. #5
    New ROGer Array BenLomax PC Specs
    BenLomax PC Specs
    MotherboardTUF GAMING x570-PLUS
    ProcessorRyzen 3 3700x
    Memory (part number)Gskill Trend Z RGB
    Graphics Card #1RTX 270

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    3

    On bios 1403 same laggy bios, i read on other forum that someone notice that unplug all usb device help him. We will see if asus will fix that.

  6. #6
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    9

    same here.

    so seems thats feature not issue

  7. #7
    New ROGer Array DragonFly1001 PC Specs
    DragonFly1001 PC Specs
    MotherboardASUS PRIME X570-PRO
    ProcessorAMD Ryzen 7 3700X
    Memory (part number)Crucial Ballistix Sport LT 2x8GB DDR4 PC4-25600 BLS2K8G4D32AESBK
    Graphics Card #1Gigabyte Windforce OC 3X 8G RTX 2070 super
    MonitorNEC EA231WMi
    Storage #1Samsung 970 Evo Plus 1Tb
    CPU CoolerAMD Wraith Prism
    CaseThermaltake Suppressor F31
    Power SupplyAeroCool P7-850W Platinum
    Keyboard HYPERX Alloy FPS
    Mouse Logitech M280
    OS Windows 10 x64 Pro
    Network RouterASUS RT-AC66U

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    14

    The same problem with prime x570 pro an all bios versions. bios run at 2-3 fps, mouse movement is very sluggish

  8. #8
    New ROGer Array BenLomax PC Specs
    BenLomax PC Specs
    MotherboardTUF GAMING x570-PLUS
    ProcessorRyzen 3 3700x
    Memory (part number)Gskill Trend Z RGB
    Graphics Card #1RTX 270

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    3

    Hi all, on days i change my old keyboard to new one, i i think laggy bios is not laggy as was on old one. I read on other forum that, switch off keyboard or change mouse can fix issue. Regards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •