Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    1

    Tuf x570 laggy bios navigation

    I get very laggy performance inside the bios. Mouse movement feels very sluggish and unresponsive, sometimes having to click something a few times for it to register. Nothing wrong with mouse either, works perfect in Windows. It's a wired Logitech G203 so it's not a wireless interference issue.

    I came from an Asus z87 Pro board with basically the same layout and it was very snappy and fast.

    Does anyone know what could be going on? I've updated to latest 1201 bios too.

  2. #2
    ROG Member Array ITAngel PC Specs
    ITAngel PC Specs
    MotherboardAsus ROG Maximus XI Extreme
    ProcessorIntel Core i9-9900K
    Memory (part number)CMR16GX4M2C3000C15
    Graphics Card #1MSI GeForce RTX 2080 GAMING X TRIO 8GB
    MonitorHP OMEN 25" FHD 144Hz.
    Storage #1SAMSUNG 970 500GB
    CPU CoolerDARK ROCK TF 220W TDP
    CaseO11-Dynamic Razer Edition
    Power SupplyCorsair RMx Series RM850x Gold
    Keyboard Razer Huntsman Elite
    Mouse Razer Naga Trinity
    Headset Razer Nari Ultimate
    Mouse Pad Razer Firefly Hard Edition
    Headset/Speakers Klipsch ProMedia 2.1 THX Certified Computer Speaker System
    OS Windows 10 Pro 64bit
    Network RouterR9000 Nighthawk X10 Smart WiFi Router
    Accessory #1 Klipsch ProMedia 2.1 THX

    Join Date
    Sep 2014
    Reputation
    10
    Posts
    9

    I am having the same issue with the Tuf x570 laggy bios navigation before and after bios update.

  3. #3
    New ROGer Array BenLomax PC Specs
    BenLomax PC Specs
    MotherboardTUF GAMING x570-PLUS
    ProcessorRyzen 3 3700x
    Memory (part number)Gskill Trend Z RGB
    Graphics Card #1RTX 270

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    2

    Hey,

    Same here, laggy bios navigation - checked on 1201 and 1202.

    Any feedback?

    Regards.

  4. #4
    ROG Junior Member Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    1

    Thought it was just me I'm having the same issue. Are there any beta bios for this board?

  5. #5
    New ROGer Array BenLomax PC Specs
    BenLomax PC Specs
    MotherboardTUF GAMING x570-PLUS
    ProcessorRyzen 3 3700x
    Memory (part number)Gskill Trend Z RGB
    Graphics Card #1RTX 270

    Join Date
    Oct 2019
    Reputation
    10
    Posts
    2

    On bios 1403 same laggy bios, i read on other forum that someone notice that unplug all usb device help him. We will see if asus will fix that.

  6. #6
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    8

    same here.

    so seems thats feature not issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •