Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
  1. #11
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    9

    Quote Originally Posted by YabaX View Post
    go to windows and disable fast startup under power options and reboot, if it didnt work, then do the following:

    disconnect your boot drive (or you can disconnect CPU FAN header) and the post screen should halt and asking you to press F1 to enter bios, go there and disable fast boot and then turn off, reconnect your boot drive and you should be good to go.
    Trying that now !

  2. #12
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    9

    (FIXED) Update finally got into bios. I disconnect the cpu fan header, and disconnect all my display ports and plugged in a hdmi onto a tv and was finally able to get the splash screen and post to be able to get into bios! Hope this helps some one else

  3. #13
    ROG Guru: Green Belt Array UltraNEO* PC Specs
    UltraNEO* PC Specs
    Laptop (Model)Dell XPS 13
    MotherboardAsus Rampage V Edition 10
    ProcessorIntel i7-6850k
    Memory (part number)G.SKILL F4-3600C17Q-32GTZR
    Graphics Card #1Titan X (Pascal)
    Graphics Card #2Titan X (Pascal)
    MonitorASUS ROG Swift PG279Q (x3)
    Storage #1Samsung 970 Pro 1TB NVMe
    Storage #2Samsung 860 Pro 1Tb (x4)
    CPU CoolerCustom Watercooled
    CaseCaseLabs SMA8
    Power SupplyCorsair AX1500i
    Keyboard Keyboard Paradise Custom
    Mouse Logitech G903
    Mouse Pad Logitech G840 XL
    Headset/Speakers ART SLA2 Linear Amp with JBL Control 5
    OS Win 10 Pro
    Network RouterPF Sense
    Accessory #1 Logitech Brio 4k
    Accessory #2 Logitech PowerPlay Game Pad
    UltraNEO*'s Avatar
    Join Date
    Dec 2011
    Reputation
    48
    Posts
    605

    FYI. Would help if you told use which mobo you was using... Some of them have a 'safe boot' switch, others don't.
    ASUS ROG RVIE Encore| i9-10940x | Dominator Platinum 128GB 3333 MHz | EVGA RTX 2080 Ti SLI | Samsung 970 Pro 1TB NVMe (x3)
    WD Black 4TB | WD Black 6TB x2 | EVGA 1600 P2 | CaseLabs SMA8 | Custom Water Cooling | HWLabs Black Ice Nemesis GTX 560
    XSPC RX 480 v3 | XSPC D5 Vario x2 | EK Blocks | EK-RES X3 400 | BitsPower Fittings | GentleTypoon 1850 x12 | Corsair SP140 x8 | Lamptron CM615

    Twitch.tv/MsNikita | Twitter.com/MsNikitaTV | Instagram.com/MsNikitaTV | Reddit.com/r/MsNikitaTV

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •