Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    1

    Exclamation GL503VS - CPU Overheating - Left Fan not working

    Hi guys,

    I have a GL503VS (1 year and 4 months old laptop).

    I started noticing some consistent FPS drops in many games. They were periodic drops from 60 FPS to 10/20 FPS, even in 10 year old games (which isn't supposed to happen in a PC with a GTX 1070).

    Then I looked in the ROG Gaming Center and I saw very high CPU core temperatures (around 95-99 °C).

    Then I noticed that the left fan of the PC is always stopped.
    I tried to update every driver of the PC and the current BIOS is 306.

    Do you guys have some idea of how could I resolve this issue or should I simply send my PC to be repaired?

    EDIT: On a similar post I saw I guy that said that his Fan started working after reinstalling Windows 10. Do you think this might work or it would be only a waste of time?

    Thanks
    Last edited by NDev11; 10-27-2019 at 07:09 PM.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    309
    Posts
    7,660

    I'd say you have two choices: Try the reinstall or try replacing the fan. It's less likely you'll find a new fan replacement but you may be able to find a pull from a used machine on Ebay.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    Banned Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    40

    and if replacing the fans, the fan connectors on the motherboard have very gentle pins that tend to bend very easily if the fan is inserted in wrong angle or using brute force.

    or have you already opened to machine for dust cleaning etc and then when you removed the fans from their connectors you accidentaly bent the pins, you should check if this is the case.
    I've seen people buying new fans and those "are broken from the beginning" when the problem is simple, bent pins.
    Last edited by chumacher; 10-29-2019 at 07:27 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •