Results 1 to 4 of 4

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    ASUS Delta - ARMA 3 distorted voice

    Hi guys, i am having som trouble with the ASUS Dleta Headset. I have the USB-c type. When i am using these on skype tlaks, or just test this Headset in Steam (mic testing) or normally inw indows everything is ok. Just in ARMA3 sounds my voice very strange like a Deamon. I asked on more than 15 servers and everyone just said that my mic is broken and that my voice sounds very strange and they muted me during the game. I just updated drivers, also tryed several settings in steam and in WIndows nothing helped. I just uninstalled Realtek audidrivers Used the USB-a dongle. My PC is a Zephyrus gx701gvr.
    Thanks for any help

  2. #2
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    17
    Posts
    1,710

    Quote Originally Posted by Andrejko View Post
    Hi guys, i am having som trouble with the ASUS Dleta Headset. I have the USB-c type. When i am using these on skype tlaks, or just test this Headset in Steam (mic testing) or normally inw indows everything is ok. Just in ARMA3 sounds my voice very strange like a Deamon. I asked on more than 15 servers and everyone just said that my mic is broken and that my voice sounds very strange and they muted me during the game. I just updated drivers, also tryed several settings in steam and in WIndows nothing helped. I just uninstalled Realtek audidrivers Used the USB-a dongle. My PC is a Zephyrus gx701gvr.
    Thanks for any help
    do you think that you mic is broken cause on arma3 there is problem and all other that is not arma is ok?

    right.

    You are using TeamSpeak?
    Learn, Play Enjoy!

  3. #3
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Hi, yes expect ARMA3 is all ok. I am using the in GAME voice chat.
    i also tried to change setting in steam SHIFT + TAB , voice chat and turn off all voice enhancements - still the same problem.
    i also see a PCI device in Device Manager as not recognized and cant update any driver - but this should not be the problem, when in all other apps the mic ist without any problems.

  4. #4
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    I just reinstalled the whole OS withou deleting my files and therefore reinstalled also all apps and it worked so, this was the only solution. I think that the problem was the sonic studio 3 which caused that the drivers stopped working properly. With only th realtek audi drivers is all ok. till now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •