Page 2 of 2 FirstFirst 1 2
Results 11 to 11 of 11
  1. #11
    Mastermind19 Array
    Join Date
    Oct 2015

    Quote Originally Posted by fifeed View Post
    Good afternoon,

    I have 2 peripherals :
    - Asus ROG Strix Flare
    - Asus ROG Gladius II

    At boot, the ROG Armoury application prompted me to upgrade the firmwares of the devices. I accepted and let the application proceed. The operation was successful for the keyboard but not for the mouse (I had a message that the firmware upgrade failed for the Gladius II). Right after the upgrade failure, the mouse stopped being detected (no led, no sensivity).

    When I look into the peripherals manager, I can see that the mouse is detected as a disk drive named "NXP LPC1XXX IFLASH USB Device" with inside a file called "firmware.bin" (with a size of 128KB). [See Picture 1]

    When I look into ROG Armoury Application, the mouse has disappeared. [See Picture 2]

    I already tried some things :
    - Plugging into another computer, it's all the same.
    - Plugging/Unplugging, it's all the same.
    - I tried to use the tool called "Gladius II FW Update Tool" (version, I get the error message "CAN_NOT_GET_HANDLE". [See Picture 3]

    The only thing I can tell for sure is that the problem came from the application Armoury, which couldn't upgrade the firmware properly.
    Of course the 2 years warranty has expired recently (planned obsolescence?).
    I have a Razer DeathAdder that lasted +10 years and is still usable today...

    I'm out of options, do you guys have any leads to solve this?

    Thank you and have a nice day.
    DId the firmware I provided work for you? Have a good day!

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts