Results 1 to 1 of 1
  1. #1
    New ROGer Array Thom75 PC Specs
    Thom75 PC Specs
    MotherboardASUS Prime X370-Pro
    ProcessorRyzen 5 2600X
    Memory (part number)Corsair CMK16GX4M2B3000C15 Vengeance LPX 16 GB
    Graphics Card #1Nvidia GTX 1050Ti 4GB GDDR5
    Graphics Card #2ASUS Nvidia GT 730 2GB
    Sound CardDAC + Class A Headphone Amplifier
    Storage #1Kingston & Intel SSD, both 120GB
    Storage #2WD Blue 2T, 1T, 500GB
    CaseFractal Design Define R3
    Power SupplyCorsair CS650M 650W
    Keyboard HyperX Alloy Elite MX Red
    Mouse RAZER Imperator 2012
    Headset Beyerdynamic DT 770 Pro
    OS Manjaro Linux 18/Windows 10
    Thom75's Avatar
    Join Date
    Jun 2019

    ASUS Prime X370-Pro, BIOS 4602 and newer breaks PCIex GPU passthrough on Linux

    Dear Asus Support,

    I'm having problem with BIOS version 4602 and newer released for the ASUS Prime X370-Pro mainboard.
    When any of mentioned BIOS versions are flashed, can't run QEMU with passthrough devices like PCIex Cards.
    Basically virtualisation is not starting up at all. I've tried flew kernel versions from 4.19 to 5.3, no difference at all, last working version of the BIOS is 4406.
    Additionally when try to run VM, it'll fails and after that I'll restart PC will freeze or even kernel panic, please see attached.
    I've tried different approach how to launch qemu via script vs VirtManager and on QEMU output I noticed error message:
    "qemu-system-x86_64: vfio: Unable to power on device, stuck in D3" which might suggest the problem.

    I hope you would be able help in this matter.

    BTW correcting title of the topic is impossible, even in advanced mode.

    Kind Regards
    Miniatura de Adjuntos Miniatura de Adjuntos KernelPanic.jpg  

    Last edited by Thom75; 11-10-2019 at 01:00 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts