Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Nov 2019

    Bios help Asus laptop X555QG

    Hello! It has past a few months until I decided to downgrade my laptop's bios, an ASUS X555QG, more specifically, with an AMD A10 APU. It seemed it went correctly, but when I tried to turn it on, I realized that it never boots. It's symptoms are these ones: It turns on with all the fans spinning and lights, and also the disc tray seems to try reading a disc always, like when an AMI bios gets corrupted. When I plug a USB on the 3.0 ports, nothing happens, but when I plug it to a USB 2.0, the USB light starts blinking, like trying to read a recovery file. I have tried: Connecting it through HDMI to a TV, putting my bios file with very different names like AMIBOOT.ROM, AMIBOOT.BIN, X555QGAS.BIN, X555QGAS.258 and many other combinations to make it work, nothing seems to happen. Also tried to hold CTRL + HOME, FN + HOME, CTRL + F2, F4, F8, and also SHIFT + WIN + B and also nothing works, I have removed the battery, for days and nothing works. PhoenixTool generates not a recovery name for this laptop's bios, but it does with other variants what results weird to me. I'd love to hear any advice from you, no matter how simple it sounds. I'm thinking of purchasing a flasher with the clip, to avoid desoldering and soldering the bios chip, but I don't really know if it would work with my board and my chip, that is a Winbond 25Q64FWSIQ 1805. Thank you in advance.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts