Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    16
    Posts
    22

    Zenith II Extreme - AMD Ryzen Master won't install

    I'm using a Threadripper 3960x with this motherboard and as the title says, Ryzen Master won't install - the installer keeps coming up with the message that "a newer version is already installed" and exits.
    Does anyone else have this motherboard and have they been able to get this utility installed?

  2. #2
    ROG Guru: Grand Master Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH II EXTREME
    ProcessorTHREADRIPPER 3960X
    Memory (part number)TXBD48G4000HC18FBK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 970/960/950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB/Samsung 1TBSSDs
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Dimastech Easy XL...let it all hang out man!
    Power SupplySeasonic 1000 Platinum
    Keyboard Corsair Strafe MK2 ROG Claymore... or Fender Rhodes Electric Piano (MKI 73)
    Mouse Corsair M65Pro or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    505
    Posts
    13,669

    Yes....same CPU same MB here...Ryzen master working

    Click image for larger version. 

Name:	mast.png 
Views:	0 
Size:	130.5 KB 
ID:	84195

  3. #3
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    16
    Posts
    22

    Thanks, I've posted on AMD forum too, with no replies. It genuinely isn't installed - there's no uninstaller and the I know I couldn't have installed the latest version since it came out weeks after everything was installed originally. I might have to reformat and install everything again, though I'd prefer not. I'm not alone with this issue - it's fairly common amongst both forums.

  4. #4
    ROG Guru: Grand Master Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH II EXTREME
    ProcessorTHREADRIPPER 3960X
    Memory (part number)TXBD48G4000HC18FBK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 970/960/950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB/Samsung 1TBSSDs
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Dimastech Easy XL...let it all hang out man!
    Power SupplySeasonic 1000 Platinum
    Keyboard Corsair Strafe MK2 ROG Claymore... or Fender Rhodes Electric Piano (MKI 73)
    Mouse Corsair M65Pro or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    505
    Posts
    13,669

    Have you tried reinstalling latest chipset drivers?...generally updating drivers?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •