Results 1 to 5 of 5
  1. #1
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    91

    Exclamation Rog Elite Arena account page is not working or missing

    I cannot go to the Rog Elite Arena site to do my daily logins or check my activity's or anything.The website says 404 -File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    I was able to go to the site and see my account and see all the points and items I could earn or redeem and what I have done in the past year and a half...

    I also cannot seem to find the review post of a laptop product I bought over a year and a half ago...it aid it was also posted then removed or missing...

    now my Rog Arena account rewards and points page is not there or working....

  2. #2
    ROG Member Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    7

    I'm having a similar problem - when I try to go to the main page, I get the navigation buttons for a second, then it redirects to a page with just some non-working links to ROG products. This is what it looks like first:

    Click image for larger version. 

Name:	ROG1.PNG 
Views:	0 
Size:	11.1 KB 
ID:	83297

    Then after auto-redirect:

    Click image for larger version. 

Name:	ROG2b.jpg 
Views:	0 
Size:	127.9 KB 
ID:	83298

    I can click the navigation links on the first page and they seem to sort of work - like the FAQ loads. But it still redirects to the second page after 2 seconds.
    The only thing that works on the second page is the drop down under the avatar - which shows my nickname, my rank, and the logout button.
    Last edited by Philomorph; 12-05-2019 at 07:21 PM.

  3. #3
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    91

    yes I am having same problem and my bookmarked actual personal account page that takes me to my point s and products to get with points gives me 404....


    I really hope they fix it....it started less than 2 weeks ago...

  4. #4
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    91

    Quote Originally Posted by Philomorph View Post
    I'm having a similar problem - when I try to go to the main page, I get the navigation buttons for a second, then it redirects to a page with just some non-working links to ROG products. This is what it looks like first:

    Click image for larger version. 

Name:	ROG1.PNG 
Views:	0 
Size:	11.1 KB 
ID:	83297

    Then after auto-redirect:

    Click image for larger version. 

Name:	ROG2b.jpg 
Views:	0 
Size:	127.9 KB 
ID:	83298

    I can click the navigation links on the first page and they seem to sort of work - like the FAQ loads. But it still redirects to the second page after 2 seconds.
    The only thing that works on the second page is the drop down under the avatar - which shows my nickname, my rank, and the logout button.
    They appeared t o have fixed it... b ut I missed 11 days of login points because of their stunt
    Last edited by AgentHunk; 12-09-2019 at 06:48 PM.

  5. #5
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    91

    Quote Originally Posted by Philomorph View Post
    I'm having a similar problem - when I try to go to the main page, I get the navigation buttons for a second, then it redirects to a page with just some non-working links to ROG products. This is what it looks like first:

    Click image for larger version. 

Name:	ROG1.PNG 
Views:	0 
Size:	11.1 KB 
ID:	83297

    Then after auto-redirect:

    Click image for larger version. 

Name:	ROG2b.jpg 
Views:	0 
Size:	127.9 KB 
ID:	83298

    I can click the navigation links on the first page and they seem to sort of work - like the FAQ loads. But it still redirects to the second page after 2 seconds.
    The only thing that works on the second page is the drop down under the avatar - which shows my nickname, my rank, and the logout button.
    They appeared to have fixed it... b ut I missed 11 days of login points because of their stunt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •