Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    3

    Question Replaced my old ROG laptop with Zephyrus GX531GX and now Overwatch Stutters horribly

    I'm in murky water when it comes to computers. I won't waste a lot of time going into what I do and don't know, but simple explanations assuming I am stupid are ok.

    (Note: I need to play on an external monitor as my eyesight is bad and the 15.6 inch laptop screen is too small for me)

    I just got a good deal on a Zephyrus S GX531GX with a GTX 2080. I did not buy it for Overwatch, however Overwatch is my current go to game til I get my VR stuff.
    Unfortunately, on the new computer, Overwatch is unplayable no matter what settings I put it on. It looks and feels like massive frame loss.

    I am using a 60hz monitor. I have capped my OW settings framerate at 60, but no matter what settings I mess with, I still get this horrible stuttering that is unplayable, and, notably, far far worse than the gameplay ability on my old ROG with a GTX860.

    Is it some kind of bottlenecking, even though I capped the frames at 60? It's just hard for me to believe or stomach that I can't play this game on settings at LEAST as good as what I had on my old computer, just because my new computer is too powerful.

    If this is my issue, is there any way to play OW smoothly on a 60hz monitor with a laptop that has that much power behind it? I probably will invest in a 144hz monitor but I'd rather not right now if I can just play OW as smoothly as I did on my weaker computer.

  2. #2
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Are you running it in Higher perfomance gpu mode? Right click the desktop, nvidia control panel and under prefered graphics processor select High performance nvidia. Under power tab select prefer maximum performance. Apply and close.

    Also open armoury crate with the key on your keyboard, mine is right above of the numpad and has an Asus logo on it, in armoury crate select Turbo mode. In the other modes I believe the RTX 2080 Max q runs at 80W TDP, selecting Turbo mode will run it at its 90W TDP mode with higher boost clocks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •