Results 1 to 1 of 1

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Dec 2019
    Reputation
    10
    Posts
    1

    G551/N551 Realtek HD audio driver with working subwoofer and MaxxAudio on win10 x64

    I have a G551JW/N551JK hybrid (G551 motherboard in N551 chasis). It used to be a N551JK with i5 and gtx850m but I decided to upgrade it with a G551JW motherboard with i7 4720HQ and gtx960m 4GB GDDR5 for better performance. BIOS version 209
    Other mods include:
    - added another 8GB DRR3L stick for a total of 16GB in dual channel
    - 1TB samsung 860 evo ssd in the sata3 hdd slot.
    - the 1TB 7200rpm hitachi hdd was moved in place of the sata2 optical drive tray with a hdd caddy. So 2TB storage in total.
    - the N551 full hd IPS screen is great so I didn't want to replace it
    - replaced the intel 7260N HMC wireless card with a 7260ac
    - replaced the stock dual band sticker antennas with metal dual band antennas from HP pavilion series (signal went from -60dB to -27dB) strongly improving the signal quality for both wireless and bluetooth. On 5GHz ac network now I easily get the full 300mbps bandwidh from the ISP
    - replaced the N551 simple copper heatsink with the extended G551 heatsink that also covers the vram and other parts around the GPU. Also replaced the stock thermal paste with Arctic Silver5. No need to worry about it being slightly capacitive if applied properly. The thermal stickers around the cpu and gpu will prevent it from leaking and touching things that it shouldnt.
    -I also plan on modding the headpipes and overlap another pair over them but that will have to wait

    Eveything works great but one thing bothers me.
    On the N551JK the sound was gorgeous using the dedicated SonicMaster subwoofer with the 6.0.1.7272 realtek driver from asus website. When connected it sounds like the low frequencies are redirected to the subwoofer and when removed it was redirected back at the built in spekers. The Maxx Audio control panel also looked more professional and the presets were great.

    Now comes the issue. With the G551JW board I can't get the subwoofer to work at all with any of the drivers from the asus website. The only one that works is the 6.0.1.7272 driver for N551JK (updated to the microsft ones from device manager then rolled back to get MaxxAudio presets working) but the MaxxAudio control panel was replaced with the ****ty ROG MaxxAudio. With the subwoofer connected it sound ok but when removed, the speker sound quality is significantly worse than on the N551. It sound tinny with no bass whatsoever.

    So here is my humble request. Did anyone with a G551JW managed to get the audio right on latest windows 10 update with subwoofer, speakers and functional MaxxAudio control panel? If so what version did you use and where from ?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •