Results 1 to 3 of 3
  1. #1
    New ROGer Array poqdavid PC Specs
    poqdavid PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardASUS GL504GW
    ProcessorIntel(R) Core(TM) i7-8750H CPU @ 2.20GHz
    Memory (part number)HMA82GS6CJR8N-VK
    Graphics Card #1Intel UHD Graphics 630 (Coffee Lake-H GT2)
    Graphics Card #2NVIDIA GeForce RTX 2070 (TU106M)
    Sound CardIntel Cannon Lake-H/S - cAVS (Audio, Voice, Speech) [B0]
    MonitorAUO B156HAN08.2 (AUO82ED)
    Storage #1Intel 660p NVMe PCIe M.2 512GB
    Storage #2Samsung SSD 850 EVO 500GB
    Mouse Logitech G903
    Headset/Speakers Logitech G633
    OS Windows 10 Home (x64) Build 18363.535
    poqdavid's Avatar
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    3

    GL504GW 100 or lower FPS on Overwatch

    Well I have a GL504GW and it was advertised that this laptop can run overwatch at 190 fps which was said here https://www.asus.com/us/Laptops/ROG-Strix-SCAR-II/ this pc never reach that advertised fps even after a clean install of windows 10

    Here is my 3DMark benchmarking
    https://www.3dmark.com/spy/10072516 (Armoury Crate Turbo setting (undervolt -59.6mV))
    https://www.3dmark.com/spy/10072684 (Armoury Crate Turbo setting (undervolt -59.6mV) PhysX Processor: CPU)

    https://www.3dmark.com/spy/10040940 (Armoury Crate Turbo setting)
    https://www.3dmark.com/spy/10040702 (Armoury Crate Balance setting)

    so I am curious is there something wrong with my laptop if anyone else can help me that has a similar device to provide a benchmark or how there device runs overwatch I would really appreciate it
    also I should mention all my drivers are properly updated
    Last edited by poqdavid; 01-07-2020 at 04:01 PM.

  2. #2
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    38

    Quote Originally Posted by poqdavid View Post
    Well I have a GL504GW and it was advertised that this laptop can run overwatch at 190 fps which was said here https://www.asus.com/us/Laptops/ROG-Strix-SCAR-II/ this pc never reach that advertised fps even after a clean install of windows 10
    Here is my 3DMark benchmarking
    https://www.3dmark.com/spy/10040940 (Armoury Crate Turbo setting)
    https://www.3dmark.com/spy/10040702 (Armoury Crate Balance setting)
    so I am curious is there something wrong with my laptop if anyone else can help me that has a similar device to provide a benchmark or how there device runs overwatch I would really appreciate it
    also I should mention all my drivers are properly updated
    we can't help if you don't provide data.
    all we can is guess.
    kinda useless.
    -> go create data -> toggle all necessary information with MSi afterburner osd (temps, cpu voltage, cpu mhz, gpu voltage, cpu core frequency and so on.. and film that with your smartphone and upload)
    provide information what drivers are you using, is your gpu configured for high perfromance? is your fan profile @ max / turbo / overboost, whatever the most powerfull one is. what is your windows power plan? so many moving parts , you see?

  3. #3
    New ROGer Array poqdavid PC Specs
    poqdavid PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardASUS GL504GW
    ProcessorIntel(R) Core(TM) i7-8750H CPU @ 2.20GHz
    Memory (part number)HMA82GS6CJR8N-VK
    Graphics Card #1Intel UHD Graphics 630 (Coffee Lake-H GT2)
    Graphics Card #2NVIDIA GeForce RTX 2070 (TU106M)
    Sound CardIntel Cannon Lake-H/S - cAVS (Audio, Voice, Speech) [B0]
    MonitorAUO B156HAN08.2 (AUO82ED)
    Storage #1Intel 660p NVMe PCIe M.2 512GB
    Storage #2Samsung SSD 850 EVO 500GB
    Mouse Logitech G903
    Headset/Speakers Logitech G633
    OS Windows 10 Home (x64) Build 18363.535
    poqdavid's Avatar
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Tor_Spo View Post
    we can't help if you don't provide data.
    all we can is guess.
    kinda useless.
    -> go create data -> toggle all necessary information with MSi afterburner osd (temps, cpu voltage, cpu mhz, gpu voltage, cpu core frequency and so on.. and film that with your smartphone and upload)
    provide information what drivers are you using, is your gpu configured for high perfromance? is your fan profile @ max / turbo / overboost, whatever the most powerfull one is. what is your windows power plan? so many moving parts , you see?
    Memory: 16384 MBytes @ 1329 MHz, 19-19-19-43
    - 16384 MB PC21300 DDR4 SDRAM - SK Hynix HMA82GS6CJR8N-VK

    BIOS: GL504GW.305, 07/11/2019
    For RTX 2070 the Driver version is 26.21.14.4166
    For UHD Graphics 630 the Driver version is 26.20.100.7584
    GPU is configured for High Performance
    Armoury Crate Profile: Balanced (Turbo doesnt make much difference)
    Power Plan: High Performance

    https://youtu.be/h337fqBj1IM I played a bit vs ai and quick play idk why but when i play with ai i tend to get more fps
    Also i couldn't use my phone to capture cause its a crappy phone and won't take clear videos for the OSD to be visible
    Well everything for sure is updated no problem with my device except that low fps
    Last edited by poqdavid; 01-06-2020 at 06:31 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •